DraftBoard
Unlimited Edition

Introduction and Tutorial

English Edition
Table of Contents

First Steps 7
  Documentation ................................................................. 7
  Registration ................................................................. 8
  System Requirements .................................................. 8
  Installing DraftBoard .................................................. 8
  File Locking ................................................................. 12
  Starting DraftBoard .................................................... 13
  Ending DraftBoard ...................................................... 13
  What's New ................................................................. 13

Quick Introduction 17
  Using a Mouse .............................................................. 17
  Parts of the DraftBoard Window .............................. 18
  Menu Bar ................................................................. 23
  Three-dimensional Design ........................................ 26
  Preferences .............................................................. 27

Basics 31
  Starting DraftBoard .................................................. 33
  Drawing a Part ............................................................ 33
  Stroke Commands ..................................................... 37
  Fillet and Chamfer ..................................................... 38
  Adding the Holes ....................................................... 39
  Making Changes ......................................................... 41
  Dimensions ............................................................... 43
  Crosshatching ........................................................... 45
  Stretching ................................................................. 46
  Rotating ................................................................. 47
  Printing ................................................................. 48
First Steps

Documentation
Registration
System Requirements
Installation
File Locking
Starting and ending DraftBoard
What's New
First Steps

The Getting Started chapter briefly describes the documentation of DraftBoard Unlimited, tells you how to install the program on your computer and use it on a Macintosh or with Microsoft Windows. It lists the type of equipment you need, tells you how to register your copy of DraftBoard and tells you how to start and end DraftBoard.

Documentation

All manuals describe DraftBoard for Windows 98, Windows ME, Windows 2000, Windows NT 4 SP5, Windows XP and for Mac OS. The user interface differs only by its appearance not by its functionality. The accompanying graphics alternately display the supported platforms.

In cases where DraftBoard functions differently on each specific computer platform instructions are provided for each platform.

When a function is available only for one of the supported platforms a note is displayed in the page margin.

The DraftBoard documentation consists of the following:

• Reference Guide
• Introduction and Tutorial

If you are already familiar with CAD software you should read the Quick Introduction chapter first and then use the Reference Guide to learn more about DraftBoard’s features and functions.

If you are unfamiliar with Macintosh or Windows programs or you need help installing DraftBoard, you should work first through the Introduction and Tutorial chapters before looking up the use of particular tools and commands in the Reference Guide.

Introduction and Tutorial

The First Steps chapter tells you how to start using DraftBoard. It briefly describes how to install the program on your computer and use it on a Macintosh or with Microsoft Windows. It lists the type of equipment you need, tells you how to register your copy of DraftBoard and tells you how to start and end DraftBoard.

The Quick Introduction chapter gives you general information about the program. It describes the basic components of DraftBoard—the mouse, window features, menus and dialog boxes. It gives a brief overview of useful features and may be all you need to know if you are familiar with CAD software.
Tutorials

The Tutorial is divided into a 2D and 3D section. All Tutorials provide step-by-step illustrated instructions to help you to become familiar with DraftBoard’s features and functions. It shows you how to use common drafting and design practices on a computer. You can learn about DraftBoard by doing the exercises in the Tutorial. If you’d rather, you can read the Reference Guide first and then go through the Tutorial to put what you've learned into practice.

Although DraftBoard offers a smooth transition from 2D to 3D you should be familiar with all 2D features of DraftBoard before proceeding with the 3D part of the Tutorial.

Registration

Contrary to popular opinion, registration cards and trash aren't synonymous. In fact, the registration card for DraftBoard, conveniently located inside your software box, is quite valuable – to you and to us. We’d really like to encourage you to return it. Filling out the registration card is a painless process. For such a minor investment of time, you’ll become a registered customer. Only by registering DraftBoard, are you entitled to receive Telephone product support and Free updates.

System Requirements

You need the following equipment to run DraftBoard:

- Pentium based processor or better or a Apple Macintosh: G3 or better).
- Windows 98/ME: 32 MB of RAM (Visualization 64 MB or better)
  Windows NT4/2000/XP: 48 MB of RAM (Visualization 64 MB or better)
  Mac OS 10: 256 MB of RAM
  Mac OS 9.x: 64 MB of RAM with activated virtual memory.
- a hard disk with 10 MB of unused space (Windows: complete installation: 35 MB; Macintosh: complete installation: 30 MB)
- a CD ROM drive for installing the software
- MS Windows or MacOS compatible Graphic card
  Macintosh: MacOS 9.2; 10.2.
- Windows: Parallel or USB interface; Macintosh: USB interface

Installing DraftBoard

DraftBoard for Windows and Macintosh comes on a CD-ROM.

Single User License

The DraftBoard Single User License can be installed on both platforms: Windows and Macintosh.

Installing a Single User License on the Macintosh

1. Insert the DraftBoard CD ROM into the CD ROM drive of your computer.
2. Start the installation by double clicking on the DraftBoard installation icon.
   The Installation menu is displayed.
3. Drag the DraftBoard installation icon to the drive on which you want the program installed.
   The program will automatically create its own folder.
4. Follow the directions on the screen
First Steps

5. When the installation is complete, click the OK button. You should read the Read me file first, since it contains information that was not available when this manual was printed.

Installing a Single User License for Windows

1. Start Microsoft Windows.
2. Insert the DraftBoard CD ROM into the CD ROM drive of your computer.
3. Start the Explorer.
4. In the Explorer click on the icon for your CD ROM drive. The content of the CD ROM is displayed.
5. Start the installation by double clicking the file Setup32.exe.
6. Follow the directions on the screen.
7. During the installation you are asked to enter your Authorization Code, that you will find on the enclosed License Agreement.
8. When the installation is complete, click the OK button. The installation automatically creates the submenu DraftBoard in the Program menu of the Windows Start menu. This menu contains besides other entries the menu item DraftBoard Unlimited 1.0 that will start DraftBoard.

You should read the Read me file first that you can open with the Readme menu item, since it contains information that was not available when this manual was printed.

Network License

The DraftBoard Network License is available for Windows and Macintosh.

There exist two methods to install a DraftBoard Network License for Windows:

• Install DraftBoard separately on each workstation and configure then the Network License as described in the following Option A section, or
• install one Network version of DraftBoard for all users on a Network Server as described in the Option B section.

In both cases the installation includes the following steps:

1. Install a Single User version of DraftBoard on the Network Server or separately for each user on its workstation.
2. Install and configure the Network License.
3. Configure the network.

Option A: Installing a Single User License for Windows

Install DraftBoard individually for each user on its workstation (not on the Server) as described in the section Installing a Single User License for Windows. Then configure all workstations as a Network version as described in the section Installing a Network license on a License Server.

You can accelerate the installation process by installing DraftBoard on one workstation and copying then the complete directory DraftBoard (that was created during the installation) to all other workstation.

Option B: Installing a Network version for Windows

When you want to install one DraftBoard version for all users on a Network server you proceed as follows:

1. Install one DraftBoard version for all users on a Network server as described in section Installing a Single User License for Windows.
2. Start the Windows Explorer on a workstation on which you want to run DraftBoard.
3. Check that the workstation is connected to the network drive on the server on which DraftBoard is installed. If not, connect the workstation to the network drive using the Map Network Drive command from the Tools menu in the Explorer menu.
4. Check that all workstation are connected to same network drive. 
   **Important**: These mapped drives must be identical on all workstations (identical drive letters)
5. Start on one workstation the program ClientCfg.exe in the DraftBoard directory using the mapped network drive and follow the instructions on the screen. 
   DraftBoard will be configured for this workstation.
6. Repeat Task 5 for all workstations on which you want to use DraftBoard.

Next you must install the Network license as described in the following section.

**Installing the Network License on the License server**

The License manager you will install distinguishes between the Server which administrates among other things the log ins and the individual Clients that request the clearance from the server to run DraftBoard.

Before you can install the Network license, DraftBoard must be installed individually on all workstations or centrally on the server for all workstations. 

**Important**: Before you can configure DraftBoard for the network, the TCP/IP protocol must be installed!

You can use any DraftBoard workstation in the network as License server. The Network License is installed as follows:

1. Connect the Wibu Network Dongle to the parallel interface of the server or the workstation you selected as License Server. 
   In case you have connected a printer to the parallel interface you can mount the dongle between the interface and the printer cable.
2. Close all programs except the Windows Explorer.
3. Double-click the file setup.exe in the Driver directory of the Dongle folder on the DraftBoard Installations CD.
4. Follow the instructions on the screen. 
   The Network License is automatically configured and an icon named Wibu key is automatically created in the Windows Control Panel.
5. Choose Control Panel from the Preferences menu in the Windows Start menu.
   The Windows Control Panel is displayed.
6. Double-click the Wibu Key icon in the Control Panel.
   The Wibu Preferences dialog box is displayed.
7. Select the Preferences tab.
8. Check the correct installation of all required drivers using the Check button in the selected tab. 
   For possible question each tab provides a Help button.

**Configuring the Network Server for Windows**

After having installed the Network License you must first configure the License server and then the individual License clients. The License server is configured as follows:

1. Copy the following files from the Server directory in the Dongle folder on the DraftBoard Installations-CD to the computer you have configured as License server. 
   • the License Manager WKServer (File name: WkSvW32.exe) 
   • the configuration and monitoring program WKMon (File name: WkSvMon.exe).
2. Start the program WKServer (File name: WkSvW32.exe). 
   This program provides the licenses for the individual workstations. In case that a License server using Windows NT is shut down more frequently, make sure that this program is restarted each time the computer is launched.
3. Start the program $WKMon$ (File name: $WkSvMon.exe$) and check the correct function of the licenses sever and the available number of $DraftBoard$ licenses.

**Configuring the Network Clients for Windows**

Next you must configure License Clients. You configure a workstation as client as follows:

1. Copy the Configuration and Monitoring program $WKMon$ (File name: $WkSvMon.exe$) from the Server directory in the Dongle folder on the $DraftBoard$ Installations CD to all computers you want to configured as clients.

2. Choose Control Panel from the Preferences menu in the Windows Start menu. The $Windows$ Control Panel is displayed.

3. Double-click the Wibu Key icon in the Control Panel. The Wibu Preferences dialog box is displayed.

4. Select the Network tab.

5. Configure WKLan as subsystem.

6. Enter the Server-IP into the Server Search list.

7. Test the configuration.

8. Close the Preferences dialog box in the Control Panel.

9. Start the program $WKMon$ (File name: $WkSvMon.exe$) and check the correct function of the licenses sever and the available number of $DraftBoard$ licenses.

**Creating an individual Preference file for a Network**

During the installation of $DraftBoard$ many default settings are saved in the $DraftBoard.ini$ file in the $DraftBoard$ folder. The $DraftBoard.ini$ file contains the following sections:

![Image](https://via.placeholder.com/150)

- **[Defaults]**
  - **DraftBoard Preference File**

  This section contains the path to and name of the $DraftBoard$ Preferences file $Prefs.vlm$ like:

  `PrefFile=c:\Programs\DraftBoard Unlimited 1.0\prefs.vlm`

  You should only enter a path for the Preference file in this section, if you don’t want to use the default preference file in the $DraftBoard$ directory.

**Creating an individual Preference file for the Network version**

If you want to create in a network an individual $DraftBoard.ini$ and $Prefs.vlm$ for each user you must proceed as follows:

1. Create a new folder (for example named Settings) on the server for all Preference and .ini files. The folder name is not important.

2. In this new folder create subdirectories for each user (for example Settings\Smith).

3. Copy the file $DraftBoard.ini$ and $Prefs.vlm$ in each subdirectory.

4. Enter for each user in the $DraftBoard.ini$ file the path to the related Preference file as follows:

   `PrefFile=d:\Settings\Smith\prefs.vlm`

5. Select in the $Windows$ Explorer the short-cut icon you normally use to start $DraftBoard Unlimited 1.0$.

6. Click the right mouse button and select in the displayed context-sensitive menu the Properties command.

7. Select in the displayed dialog box the Connections tab.

8. Enter in the Target entry box after $DraftBoard.exe$ a space and then the path to the $DraftBoard.ini$ file for example to Mr. Smith.

   `C:\Programs\DraftBoard Unlimited 1.0\draftboard.exe /i:d:\Settings\Smith\draftboard.ini`
First Steps

File Locking
When ever a simultaneous file access is possible from several
workstations File Locking must be activated. This is always true
when a DraftBoard Network version or more than one single user
version of DraftBoard is installed on a network.
For a single user version File Locking should be switched OFF
(default setting).
File Locking prevents that several users can edit a file simultaneously.
To enable a controlled file access for several users in a network you
must first
• activate File Locking, then
• create a file named Public.key and finally
• copy this Public.key file to all directories accessed by the us-
ers.

Activating File Locking
1. Open the draftboard.ini file in the DraftBoard directory with a
common Text editor such as the Windows program Edit.
2. In the DraftBoard.ini file search for the section
;File Locking
3. Substitute the entry
FileLock=OFF by FileLock=ON
4. Save the draftboard.ini file.

Creating the Public.key file
The key file required for File locking can be created with any
Text Editor. The content of the file is unimportant. The file can be even
empty, only the file name Public.key is important. The Public.key file
can be also created by renaming a file.
1. Start a Text Editor.
2. Open a new file.
3. Save the file as Public.key.

Placing the Public.key file
The file Public.key must be copied into all directories that contain
DraftBoard drawings and can be accessed by more than one user.
It is not imperative to copy the Public.key file into the directory
containing DraftBoard drawings, it also can be copied further up the
directory tree. In this case the Public.key file controls the directory it
is copied to and all subdirectories contained in this folder.

WIN
An example for a public.key
file you find in the Draft-
Board directory.

How File Locking works
The File Locking integrated into DraftBoard works as follows:
• When DraftBoard is launched it checks if File Locking is
activated in the draftboard.ini file by the entry
FileLock=ON
• If that is true, DraftBoard checks while opening or saving
a drawing if the selected directory is released by a Public.key
file.
• If DraftBoard doesn’t find in any directory of the selected
drive a file named Public.key, the drawing can be opened only
with read rights and saved locally on the workstation.
• If the selected directory is released by a Public.key file
DraftBoard creates a so called LOK File with the name of
the drawing and the file extension .lok.
The LOK File contains the following data:
User name, file path, file name, date and the current
Time using the format
<Locked:08-13-1998 11:34>
• As long as this LOK File exists the logged in user owns all
rights for reading and saving the drawing. All other users are
only allowed to read this file. When the drawing is closed the
related LOK File is automatically deleted.
Possible Problems and Error Messages

The following problems can occur when File Locking is activated:

- The selected drawing can be opened on the released network drive with read rights only.

Possible Problems:

- There exists no Public.key file or
- the drawing is already accessed by another user. In this case a LOK File with the name of the drawing must exist. The LOK File contains the name of the current user.

Solution:

- Create the missing Public.key file or wait until the drawing is released by the current user.
- When opening a drawing the following error message is displayed:

  The selected drawing is registered as open. Do you want to open it anyhow?

Possible Problems:

- For the selected drawing still a LOK File exist that wasn’t deleted when the drawing was closed due to a computer power failure.

Solution:

- Click the Yes button. The drawing is opened with all rights.

Starting DraftBoard

Windows

1. Connect the enclosed Dongle to the parallel or USB interface of your computer. If you want to connect your computer to a printer using the parallel interface, the printer cable can be connected directly to the dongle.
2. Start your computer.
3. Select the menu item DraftBoard Unlimited 4.5 in the DraftBoard Unlimited 1.0 submenu in the Start menu.

Macintosh

1. Connect the enclosed Dongle to the USB interface of your computer. The mouse or keyboard cable can be connected directly to the dongle.
2. Start your computer.
3. Locate the DraftBoard Unlimited 4.5 icon.
4. Double click the DraftBoard icon to launch the program.

Ending DraftBoard

1. Click File in the DraftBoard menu bar to display the File menu.
2. Select the menu item Quit in the File menu and click.

What’s New

DraftBoard Unlimited 4.5 offers the following new features:

- Rectangle tools
  The Polygons subpalette contains four new Rectangle tools, for creating polygonal rectangles, that can be selected and edited as one object. They are marked by a small R in the tool symbol.

- Line styles
  In Version 4.5 you can define in addition to the 11 predefined line styles another 19 line patterns.

- Moving Screen Contents
  The new tool Pan Drawing area allows to move the content of a screen. You find this tool in the Views subpalette.
• **Saving Drawing Areas**
  A Viewport Manager allows you to save screen contents with their current zoom factor. The Viewport Manager is a big help when navigating through large 2D drawings.

• **Bringing Objects forward/backward**
  A new command sorts objects on the screen by bringing them to the front or back. Sorted objects in the foreground will cover objects in the background.

• **OLE Support for Text and Files**
  Text can be moved directly from all programs that support OLE into the DraftBoard drawing area. DraftBoard files will be directly opened, when moved from the Windows-Explorer or from the Windows Desktop into the DraftBoard drawing area.

• **Default Directories**
  For Opening, Saving, Import- and Exporting documents you can set default directories.

• **Document Properties**
  Specific document properties and a drawing preview can now be specified for all DraftBoard Documents.

• **Dimensions**
  DraftBoard Version 4.5 offers new dimensions such as ordinate dimensions, extended radial dimension or dual dimension formats.

• **Hatches**
  DraftBoard 4.5 allows to define the origin of hatch patterns.

• **Projection of all View windows**
  All Detail View Windows can be projected onto one model. A feature that is important for exporting data into other program data formats.

• **Symbol Layer Structure**
  Symbol can keep now their layer structure when placed into a DraftBoard document.

• **Visualization of Objects**
  The integrated OpenGL Support for Windows allows now to rotate and edit 3D Models in real time in the View Modes Shaded and Visible Lines.

• **Calculation of Intersections**
  An additional analytical view mode represents all visible model edges as NURB Splines and calculates precisely all edges including all sorts of intersection and hidden lines.

• **New Data Interface**
  Document attributes including a preview of the drawing can be exported into EDM/PDM-Systems.

• **New Import-/Export-Filter**
  DraftBoard 4.5 contains now a completely revised DWG/DXF Filter and new data formats such as EPS, STL or PNG.
Quick Introduction

Using a Mouse
Parts of the DraftBoard Window
Menu Bar
Three-dimensional Design
Preferences
Quick Introduction

This chapter describes the basic components of DraftBoard—the mouse, window features, menus, and dialog boxes. This is a brief overview of useful features and may be all you need to know if you are familiar with CAD Software.

Using a Mouse

The mouse is your communication device; you use it to tell the computer what you want to do. You will use the mouse to indicate locations, choose commands, select tools, and construct objects.

If your mouse has more than one button, you will use only the left button with DraftBoard.

This manual uses the following terms for mouse activities:

**Pointer** An arrow or other graphic symbol that allows selection or creation of an object. You move the pointer to point to a command or an object on the screen. Depending on its location, the pointer is an arrow or looks like the current tool.

**Arrow Pointer**

**DraftBoard Selection Arrow**

**Center-Point Circle Arrow**

To move the pointer, move the mouse on the mouse pad. You use several different mouse actions with DraftBoard.

**Point** Move the mouse until the pointer is over the item you want.

**Press** Press and hold down the mouse button.

**Click** Quickly press and release the mouse button once.

**Double-click** Click the mouse button twice, quickly in succession.

**Drag** Press and hold down the mouse button, move the mouse, then release the mouse button.

If you need more information about standard Windows elements such as menus, scroll bars, File menu commands, and dialog boxes, refer to your Macintosh or the Microsoft Windows User’s Guide.

If you are left-handed and if your mouse has more than one button, you may want to change the functionality to the right mouse button. You can make this change in the Control Panel of Windows.
Parts of the DraftBoard Window

When you start DraftBoard, the following window appears:

Title Bar
Includes the title of the active document and two buttons: the Zoom box and the Close box, for controlling the window.

Menu Bar
Contains the DraftBoard menus of commands and settings. You can make choices from the menus with the mouse or by using special key combinations.

Message Line
Displays the name of the current tool and step-by-step instructions for using the tool.

Tool Palette
Contains the drawing and editing tool icons you will use for constructing, editing, and annotating geometry.

Drawing Area
Consists of multiple layers where you construct and annotate geometry.

Pointer
Shows the active position on the screen. If the pointer is in the drawing area, its shape represents the current tool.

Layer Indicator
Displays the name of the current layer and provides a menu for changing the work layer.

Line Indicator
Displays the name of the line style and provides a menu for changing the line style.

Location Indicator
Shows the x,y coordinates of the pointer location.

Status Line
Shows the coordinate location and other geometric parameters of the current construction.

Scroll Bars
Allow you to move around a drawing so you can see different sections of it through the DraftBoard window. The scroll buttons allow you to move one line at a time.

Windows Title Bar
The Title Bar includes the name of the current document and also the Control Menu, Minimize, Maximize/Restore and Close buttons.

Control Menu button
Allows you to close, move, and change the size of the window. This button is available on all windows and many dialog boxes.

Double clicking this button closes the window without displaying the menu. If you want to choose a different option from the Control Menu, click the button.
once to display the menu and then make
your choice

Minimize button
Reduces the DraftBoard window to
an icon near the lower-left corner of
the screen. This action does not close or
save the document, it only shrinks the
Windows-related task. To redisplay the
window, double-click the icon.

Maximize/Restore button
Displays the window full or partial screen.
Once the window appears full screen,
click the button again to restore it to its
previous size.

Close Box
Clicking the button closes the window. If
you attempt to close the window without
saving your work, DraftBoard displays
a message so you can decide whether to
save or not.

Macintosh Title Bar
The Title Bar includes the name of the current document and also the
Close box and the Minimize and Maximize buttons.

Close button
Clicking this button closes the window.

Minimize button
Reduces the DraftBoard window to
an icon near the lower-left corner of
the screen. This action does not close or
save the document, it only shrinks the
Windows-related task. To redisplay the
window, double-click the icon.

Maximize/Restore button
Displays the window full or partial screen.
Once the window appears full screen,
click the button again to restore it to its
previous size.

Tool Palette
The tool palette is a group of tool icons along the left side of the
screen. The icons represent the tools for drawing, editing, and
annotating geometry.

Selecting a tool from the tool palette
1. Position the arrow pointer on the icon of the tool you want to
   use.
2. Click the mouse button.

The icon appears highlighted to indicate its selection. The Single Line
tool is selected above.

Tool Subpalettes
Most of the tools in the tool palette contain a subpalette of tools with
related functions. The ▶ in the lower-right corner of the tool icon
shows the presence of a subpalette which contains related tools.
Viewing and selecting from a subpalette are similar to choosing a command from a menu.

**Selecting a tool from a subpalette**

1. Position the arrow pointer on the tool.
2. Press and hold down the mouse button.
   
   The subpalette appears to the right of the tool.

3. With the mouse button pressed, **drag** the pointer to highlight the desired tool.

4. Release the mouse button.
   
   The selected tool replaces the previous tool in the tool palette. The highlighted icon in the tool palette shows that your selection from the subpalette is the active or current tool.

   The new tool is visible in the tool palette until you select another tool from the same subpalette. The tools on the subpalette remain in the same order; only the tool displayed on the tool palette changes.

Once you select a tool, additional information appears to help with your construction. The pointer, pointer locator, message line, and status line all provide feedback about the active tool.

**Smart Pointer**

When you select a tool and move the pointer into the drawing area, the pointer shape is representative of the tool.

Some of the pointers, like the single line pointer, are simple crosshairs. Others, such as the **opposite-point circle** pointer, resemble the tool itself.

The pointer, called a **smart pointer** displays indicators for multi-step procedures. Each smart pointer has a dot, the **hot spot**, showing the next point you should specify. The dot changes position on the pointer during each step of the construction.

For example, the **opposite-point circle** pointer illustrated above shows that the first click of the mouse places a point on one edge of the circle you’re creating. After you click a location, the hot spot moves to the other side of the pointer, showing that the next click places a point on the opposite edge of the circle.
Quick Introduction

After you click the second location, the circle appears. The hot spot moves back to its original position on the pointer so that you can create another circle.

**Location Indicator**

The location indicator is two numbers to the left of the horizontal scroll buttons at the bottom of the drawing area.

This indicator continuously tracks the pointer location when the pointer is in the drawing area, displaying the X,Y coordinates of the current location relative to the origin. The origin (0,0) is in the center of the screen when you open a new document. A symbol appears at the origin (0,0) when you make the grid visible by choosing **Show Grid** from the **Layout** menu.

**Message Line**

The message line across the top of the drawing area provides concise instructions for the use of the current tool.

For example, after selecting the **Center-Point Circle** tool, the message line appears as illustrated below:

The instructions in the message line for some tools also indicate optional activities. For example, if you hold down the **Ctrl** key (Macintosh: **Option key**) while using the **Center-Point Circle** tool, the next mouse click creates a copy of the last circle with the center placed where you clicked.

**Status Line**

The status line provides measurements, angles, X,Y coordinates and delta values for the current construction. The current tool determines the number of status boxes and which of the status boxes is highlighted after the construction. For example, if you select the **Center-Point Circle** tool, the status line shows the X,Y coordinates for the center of the circle and the length of the diameter.

When you click the last point of the circle, the diameter (D) entry box highlights in the status line to indicate that it is active. It shows the diameter of the circle you just created. If you type a new number, and press the **Enter** key, the diameter of the circle you just created changes.

You can change any or all entries in the status line, but when you press the **Enter** key, you can't make any more changes in the status line.

**Moving between status boxes**

You can use the **Tab** key to move to the right, highlighting the next box. When you press the **Enter** key, the construction redraws according to the new specifications in the status line.

**Drawing Area**

You use the drawing area for all construction, editing, and annotation of geometry. You can think of the drawing area as a sheet of paper of unlimited size that you can use to construct full-size unscaled drawings. You can use the scroll bars to move the sheet so the portion you want to work on is visible in the window.
Quick Introduction

Displaying the grid

If you wish to work with a grid in the drawing area, choose Show Grid from the Layout menu.

When the grid is visible, constructions snap to the grid, meaning that any geometry point that you click snaps onto the closest grid point. The coordinate symbol appears at the origin when the grid is visible.

Scroll Bars

The scroll bars allow you to move the sheet up and down or right and left. You can display different parts of the drawing sheet by dragging the slider of a scroll bar to the approximate location. For example, the right, center, or left position in the horizontal scroll bar displays the right side, middle, or left side of the drawing.

You can also click the arrows at the end of the scroll bars to move the sheet one line at a time. If you click in the scroll bar, the sheet moves one window at a time.

Work Layer Indicator

The Work Layer in the lower-left corner of the screen shows the current layer. New geometry goes on the work layer. If you want your construction to go on a different layer you must change the current work layer.

To select a new work layer, position the pointer over the Layer indicator, then press and hold down the mouse button. All available layers will be displayed in a pop-up menu.

You move the mouse pointer with the left mouse button still pressed over the layer which should become the work layer and release the mouse button. The selected layer becomes the new work layer.

Pen Indicator

The Pen Indicator in the lower-left corner of the screen shows the current pen. If you want to use a different line style you must change the current pen.

To select a new pen, position the pointer over the pen indicator, then press and hold down the mouse button. All available pens will be displayed in a pop-up menu.

You move the mouse pointer with the left mouse button still pressed over the pen which should become the current pen and release the mouse button. The selected pen becomes the new line style.
Menu Bar

The DraftBoard menus contain related commands and settings.

File
Commands that affect entire documents (files).

Edit
Commands to select and manipulate objects.

Layout
Commands and settings that specify the drawing area and provide program features and functionality, such as construction lines and 2D analysis.

Arrange
Commands for zooming to change the area displayed in the window. You can also set specifications for objects.

Pen
Commands to specify pen characteristics: style, color, weight, and pattern. Crosshatching and arrows are also available on this menu.

Text
Commands to set the font, size, style, alignment, and indentation of text.

Dimension
Commands that specify dimensions and their format and tolerance.

Views
Commands to control multi-page documents and the orientation control of 3D objects.

3D
Commands to set the 3D planes and to create three-dimensional objects.

Utilities
Commands to create Macros and to add additional functions and commands into DraftBoard.

Modules
Modules as Bill of Material or Nesting that can installed additionally to DraftBoard.

Help
The Help menu provides access to the Reference Guide and Tutorial of DraftBoard.

Displaying a DraftBoard menu
1. Position the arrow pointer on the menu name.
2. Click the mouse button.

Choosing a command from a menu
1. Position the arrow pointer over the menu name.
2. Press and hold down the mouse button.

The menu appears. If you want to dismiss the menu without making a choice, click outside the menu.

3. With the mouse button still pressed, drag the pointer down the menu. Each command highlights as the pointer moves over it.
4. When the command you want highlights, release the mouse button.

The command executes, or the setting, such as Selectable Points, toggles on or off.
Quick Introduction

Mouse versus Keyboard

DraftBoard’s menu items can be chosen with the mouse or with a combination of keys on the keyboard.

For example, you can use with Windows any of three methods for displaying the Edit menu:

• Click on Edit in the menu bar.
• Press the Alt key and then type E (for Edit).
• Press the Alt key and then press the right Arrow key until Edit is highlighted in the menu bar; then press Enter.

You have three methods for choosing commands with the keyboard. For example, you could use any of the following methods to choose the Show Grid command from the Layout menu:

• Press Alt and L (for Layout) and then type G (for Show Grid).
• Press Alt then use the right Arrow key to highlight Layout and press Enter.
• Hold down the Ctrl key and type G (for Show Grid).

The first method is the mnemonic method. You press the Alt key with the appropriate letters for the menu and command as indicated by the underlined character in the names. The third method is a keyboard accelerator and, when available, is denoted by the key sequence listed on the menu.

On the Macintosh too menu items can be chosen with the mouse or with a combination of keys on the keyboard.

Many of the menu items have a Command (⌘) key sequence that are listed beside the command in the menus for issuing them from the keyboard. For example, you can choose the Print command by holding down the ⌘ key and pressing the letter P on the keyboard. While keyboard functionality is always available, this manual generally describes making choices only with the mouse.

Submenus

Commands followed by a symbol have submenus which display when the command is highlighted.

1. Pull down the menu.
2. Drag to highlight a command followed by a symbol. The submenu displays.
3. With the mouse button still pressed, drag over to the submenu.
4. Drag down the submenu until the desired command is highlighted.
5. Release the mouse button.

Dialog Boxes

When you choose a command followed by an ellipsis (.), such as Edit Objects on the Edit menu, a dialog box appears.
Dialog boxes allow you to qualify the command you chose by adding information. For example, in the Edit Objects dialog box above, you can change the specifications of the selected object.

If a dialog box obscures your view of the drawing area, you can drag it with the pointer on the Title bar to a new location.

**Option Buttons**
Option buttons indicate mutually exclusive choices; you can select only one option at a time (as you might select a station on your car radio). Click the option you want and the button turns black, as shown by the inches option above.

**Check boxes**
Check boxes provide options you can switch on and off and which are not mutually exclusive. An X shows the option that is set.

**List/Entry boxes**
Some dialog boxes contain lists of options, displaying a drop shadow to show that a pop-up menu exists. Move the pointer to the entry box and press the mouse button to display the list.

The item you highlight appears in the box once you select it.

Some list boxes as the Scale box in the Drawing Size dialog box allows you to type an entry as well as choose from the pop-up menu.

To type an entry, select the current entry (if it isn’t already selected), then type a new entry. The new entry replaces the original entry.

**Asterisks**
When an item in the dialog box displays an asterisk (*), you can specify a value by clicking or dragging in the drawing area. This feature is particularly useful for specifying location because you don’t need to know any x,y coordinates.

**Apply Buttons**
Some dialog boxes have an Apply button that allows you to apply the specification you just set. You can leave the dialog box open to set other specifications.
Quick Introduction

For example, once you crosshatch a part, you could leave the Crosshatch dialog box open and select other objects to be cross-hatched.

Closing a dialog box
If a dialog box contains an OK or Cancel button or an action button such as Open, the dialog box closes when you click the button. Otherwise, you dismiss the dialog box by clicking the Close box in the upper-left corner of the box. If the dialog box has an Apply button, such as the Crosshatch box, you must click the Close box to close it.

Toggling Commands
Commands that set a condition (such as Selectable Points and Arrow At Start) display a checkmark ✓ in the menu to indicate that they are active. To turn a command off, choose it and the checkmark will disappear.

In the case of pen styles and text characteristics, the check shows the current setting.

Other commands, Show Grid, Show Points, and Show Palette, toggle to Hide (Grid, Points, or Palette) when the component is visible.

Three-dimensional Design
When you launch DraftBoard or open a new document, you can start your two-dimensional design right away since you are looking down on top of the drawing area.

If you want to create three-dimensional objects, you must select a three-dimensional view. For that purpose, you choose the Trimetric view from the submenu Views in the Views menu.

When you start drawing using the Connected Lines tool, the dynamic construction lines of the Drawing Assistant are aligned trimatrically and all related 3D snap points and notations are displayed.

To calculate the three-dimensional surfaces, select the entire geometry and choose the AutoSurface command from the 3D menu. The automatically calculated NURB Surfaces are displayed as a wireframe surface mesh.
If you want to display the surfaced geometry in a Hidden Line or Shaded view mode, select the related command from the View Mode submenu in the Views menu. But first you should select the surfaced geometry and change the line color to Grey using the Color Palette in the Color submenu of the Pen menu.

Preferences

All files are saved with the settings as they are established when you close the file. The default characteristics used for new files are contained in the preferences file. The preferences file name is Prefs.vlm (Macintosh: draftboard.prefs). This file must be in the DraftBoard folder.

If you want to use different settings for your work, you can change and save the default settings using the Save Preferences command in the Layout menu. Every new document will then open with the new default settings. The following specifications can be set in the preferences file:

- Pen styles
- Text characteristics and margins
- Preferences settings (snap, grid, units, and selection indicator etc.)
- Grid display
- Layer and sheet specifications
- Work Layer
- Dimension and tolerance formats
- Arrowhead type and display
- Drawing size and scale
- Zoom scale
- Fillet radius
- Chamfer angle and length
- Resolve values
- AutoSave settings
- Visualization settings

Changing the default settings

1. Create a drawing with the settings you want for each new drawing.
2. Choose the Save Preferences command in the Preferences submenu of the Layout menu.

The preferences are set for all subsequent new documents.

Important: The Save Preferences command doesn’t save any geometry. That means when you choose this command only the current settings are saved for future documents but not the drawing itself.
Basics

Starting DraftBoard
Drawing a Part
Stroke Commands
Fillet and Chamfer
Adding the Holes
Making Changes
Dimensions
Crosshatching
Stretching
Rotating
Printing
Basics

This tutorial is primarily for engineers, designers, drafters, architects, and technical illustrators, especially those who are new to computers. The exercises demonstrate DraftBoard’s most powerful features so you can see how the patented Drawing Assistant simplifies computer-aided design and drafting (CADD).

You will soon integrate what you already know about design and drafting with the power of a computer, making your work faster, more accurate, and more creative!

If you are new to computers, CAD may feel awkward and uncomfortable at first. A frustrating truth about computers is that you have to figure out how the computer wants it done. However, once you see what you can do and how easy it is to make changes such as adapting a standard part to new specs, we think you’ll agree that the "kick in the side of the head" is worth the effort.

So, be prepared to look at things differently. Go through these exercises, and then begin to adapt DraftBoard’s power to your personal work style.

What You Will Construct

In these exercises you will construct this part using computerized fillets, chamfers, crosshatching, and dimensions.

You will perform the following tasks:

• Open DraftBoard
• Choose from menus
• Create geometry
• Change geometry
• Use the Drawing Assistant
• Create construction lines
• Save a document
• Stroke to create construction lines
• Stroke to zoom
• Create chamfers and fillets
• Construct circles
• Trim
• Change the characteristics of lines
• Dimension
• Crosshatch
• Stretch
• Rotate
• Print
Conventions

The numbered tasks in these exercises describe the activity you are to perform, and the bulleted steps beneath the numbers tell you how to accomplish the task. If you already know how to accomplish the task, you should do it without following the bulleted directions, and then proceed to the next numbered task.

Notes in the margin provide extra information throughout the exercises. You can omit reading these notes and still perform the tasks described. If you want to learn more about DraftBoard, however, you should read them as you go or come back to them once you finish the exercise.

Exploring

Some users like to go off on their own to explore while going through the exercises of a tutorial. This is an excellent way to learn more about DraftBoard. If you are adventurous, open a new document for your explorations and then switch back to the tutorial document when you want to continue with the exercises.

Occasionally, the tutorial may verify a position or entry that seems obvious to you. If the condition is vital to the next step and you might have inadvertently deviated from the tutorial path, verification (for example, "the x,y location is 0,0") has been added to ensure that you get the correct result from the exercise.

There's More than One Way

DraftBoard often provides more than one way to perform a task. This tutorial describes only one method at a time and may show you a different way to do the same task later. When you start to develop a preference, feel free to substitute your own method for whatever is suggested here, provided you're certain that your method produces the same outcome as the tutorial.
Starting DraftBoard

In this exercise, you will start DraftBoard.

1. Start your Computer.
   - MAC
2. Double-click the DraftBoard Group to open it.
3. Double-click the DraftBoard icon.
   - WIN
2. Choose DraftBoard Unlimited 4.5 in the DraftBoard Unlimited submenu of the Programs menu from the Windows Start menu.

DraftBoard opens, displaying a document named Untitled 1 with an empty drawing area.

Drawing a Part

In this exercise, you will construct the basic shape of the part.

1. Select the Connected Lines tool.
   - Move the pointer to the Single Line tool icon on the tool palette and press (hold down the left mouse button) the Single Line tool.

   The subpalette appears.

   • Drag across the subpalette until the Connected Lines tool is highlighted, then release the mouse button. Drag means to press the mouse button, move the mouse, then release the mouse button.

   The message line tells you that the Connected Lines tool is in effect. It remains the active tool until you choose another tool.

2. Draw the first vertical line 8 cm long.
   - Position the pointer in the lower left of the drawing area approximately as shown by the x below.

Make sure that the enclosed dongle is connected to your computer. If not DraftBoard will not start nor print or save.
Basics

The Drawing Assistant’s construction lines aid in precise placement. The predefined construction lines are vertical, horizontal, and at a 45° angle to existing geometry points. When the pointer is near such a location, the construction line appears and the word on appears next to the pointer. The Drawing Assistant doesn’t require you to be exact, only close enough to display the feedback. Once you click, the Drawing Assistant locks onto the exact location. Whatever you type will automatically go into the Length status box.

• Click to set the first point.
• Move the pointer up until the Drawing Assistant’s vertical construction line appears.

• Move the pointer a couple of inches from your last point (you don’t need to be exact), and when on appears on the construction line, click to set the new point on the construction line.

At the bottom of the DraftBoard window, the status line displays these boxes.

• The numbers on your screen may not match the numbers in this illustration.
• Use either the keypad or the numbers at the top of the main keyboard to type 8 and press Enter.

The length goes into the status box and the line is redrawn to exactly 8 cm, beginning at the first position you indicated.

3. Construct the second line 4 cm long at a 45° angle at the end of the first line. (Angles are measured from horizontal, not from the previous line.)

• Click to set a new point 3 cm or so from your last point.
• Type 4 and press Enter.

The line segment is constructed at a 45° angle.

4. Construct a horizontal line 6 cm long.

• Move the pointer to the right to display on for the horizontal construction line.
• Click a few centimeters from your last point.
• Type 6 and press Enter.
A 6 cm horizontal line is drawn.

5. Construct a vertical line that ends on the horizontal construction line through the upper endpoint of your first line.
   • Move the pointer straight down until **intersect** appears, then click to set a point at this intersection.

6. Use a command from a menu to create a construction line beginning at the endpoint of the last line and at an angle of -55° and then use it to draw a 3-cm line.
   • Move the pointer to the word **Layout** in the menu bar.
   • Press and hold down the mouse button and **drag** down the **Layout** menu until **Construction** is highlighted.
   • Release the mouse button.
     
     The **Construction** dialog box appears. When the pointer is in the dialog box, the angle box is highlighted. You can enter an **angle** for the construction line or an **offset** from the point specified by the coordinates. In this step you are entering an angle for the construction line.
     
     • Enter -55 (be sure to type the minus sign).
     • Click **Apply**.

A permanent construction line appears as a dotted line on the screen.

   • Close the **Construction** dialog box by double-clicking the **Close box** on the upper-right corner (Macintosh: upper left corner).

   • Click on the construction line, about 2 cm from your last point.
* Type 3 and press Enter.

The line is constructed at a -55° angle.

7. Construct a 6 cm horizontal line.
   * Move the pointer to the right to display the horizontal construction line through the endpoint of the last line.
   * Click.
   * Type (5+7)/2 in the length status box and press Enter.

The 6 cm line appears.

8. Construct an arc from the right endpoint of the last line to a point horizontally aligned with the first point of this exercise.
   * If part of the construction is now off-screen, choose Zoom Out from the Arrange menu to display the entire part on the screen.
   * Hold down the Ctrl key (Macintosh: Option key), then move the pointer straight down until intersect appears. (Note: The pointer changes to an arc.)
   * Click the mouse button.
   * Release the Ctrl key (Macintosh: Option key).

The arc appears.

9. Close the figure.
   * Move the pointer horizontally to the left to display the endpoint notation for the first line you created.
   * Double-click to set this point and signal that the connected-line figure is complete.

The outline of the part is now complete.

10. Save the drawing.
    * Choose Save from the File menu.
    A dialog box appears so that you can name the drawing.
    * Type part1 and press the Enter key (Macintosh: Return key).

Accomplishments

* Selecting a tool from the tool palette.
* Constructing a part with the Connected Lines tool.
Basics

• Using the Drawing Assistant.
• Choosing from a menu
• Creating a construction line.
• Saving a document.

Stroke Commands

Before proceeding with the drawing, examine the use of Draft-Bard’s stroke commands for creating construction lines, zooming, and displaying points. For stroke commands, hold down the Ctrl and Shift key (Macintosh: Command key) and drag the pointer across the screen or click as needed.

Drag Construction Lines

Vertically

A vertical construction line through the first point of the stroke.

Horizontally

A horizontal construction line through the first point of the stroke.

Drag diagonally

Zoom

Upper left to lower right

Zoom-in enlargement centered over the stroked area.

Lower right to upper left

Reverses zoom-in stroke to the previous magnification.

Upper right to lower left

Zoom-out reduction, the current screen reduces to the size of the area defined by the stroke.

Lower left to upper right

Reverses zoom-out stroke to previous magnification.

Click

Point Display

On object

The display of the object’s points is turned on or off.

You can use stroke commands while you are using any tool. The possible effects you can obtain with a stroke command depend on the direction you move the pointer. Even though you can create construction lines and zoom in other ways, the stroke commands come in handy because you can use them while you are in the process of using tools from the palette.

1. Create a horizontal construction line.

• Hold down the Shift and Ctrl key (Macintosh: Command key).
• Position the pointer at the lower end of the -55° line so that endpoint or intersect appears.
• Drag left horizontally.

These construction lines are placed on the construction layer and can be removed by the Delete Constructions command on the Layout menu. Since the work layer is transparent, you can see everything on the construction layer.

This command corresponds with the Show/Hide Points in the Layout menu.
The pointer trails a dotted line as you drag. Don’t worry if the line isn’t straight.

- Release the mouse button.

A horizontal construction line appears. Now, you have two construction lines which remain until you delete them.

2. Add a vertical construction line.
   - Hold down the Shift and Ctrl key.
   - Position the pointer at the midpoint of the uppermost horizontal line.

   - Drag down vertically.

   A vertical construction line appears. You’ll use these two construction lines later in the tutorial.

3. Use the stroke command to zoom in on a corner of the drawing so that you can fillet it in the next exercise.
   - Hold down the Shift and Ctrl key (Macintosh: X key).
   - Drag as illustrated from above and to the left of the upper-right corner of the drawing across the corner.

The corner is magnified.

Since all tools work at any magnification, you can repeat this action for further magnification.

**Accomplishments**

- Creating a construction line by using a stroke command
- Zooming in with a stroke command

**Fillet and Chamfer**

In this exercise, you will fillet one corner of the part and add a chamfer to another.
1. Fillet the corner you zoomed in on in the last exercise.
   • Click the 2-Entity Fillet on the tool palette.

   • Click the horizontal and vertical lines that intersect to form the corner.

   The fillet is drawn with a radius of 0.8 cm, and the corner is automatically trimmed away.

2. Return the drawing to its original size.
   • Hold down the Shift and Ctrl key (Macintosh: key).
   • Drag the pointer from the lower right to the upper left of the drawing area.
   • Release the Shift and Ctrl key (Macintosh: key).

3. Add a chamfer to the lower-left corner of the part.
   • Press the Fillet tool to display the subpalette.
   • Select the Chamfer tool.

   • Hold down the Shift key.
   • Click inside the lower-left corner of the part.

   The chamfer is drawn 0.8 cm from the original corner.

4. Save your work.
   • Choose Save from the File menu.

   Since the drawing is already named, the part is saved without displaying the dialog box. The length of time it takes to save depends on the complexity of the part you are drawing.

   **Accomplishments**
   • Constructing a fillet
   • Zooming out by using a stroke command
   • Constructing a simple chamfer

**Adding the Holes**

In this exercise, you will add two holes to the part, one of which will be offset from a specified location.
1. Construct a hole, 5 cm in diameter, centered at the intersection of the vertical and horizontal construction lines you created in Exercise 2.
   • Click the Center-Point Circle tool.
   • Click the intersection of the horizontal and vertical construction lines to indicate the center of the circle.
   • Move the pointer an inch or so in any direction and click. A circle is drawn with the center point in the location you specified.
   • Enter 5 in the D (Diameter) box on the status line.
   • Press Enter key (Macintosh: Return key).

The circle is redrawn with a diameter of 5 cm.

2. Construct a 4-cm hole that is offset 0,2 cm in the negative x-direction from the center of the arc of the part.
   • Move the pointer over the arc until the Drawing Assistant displays the + indicating the center of the arc.
   • Move the pointer to the + to display the center feedback.
   • Click to position the center of the circle.
   • Enter 4 in the D (Diameter) box but do not press Enter.
   • Click in the X box on the status line to place the text cursor at the end of the existing entry.
   • Type -0,2 (don’t forget the minus, you are creating an equation from the existing X value) and press Enter.

The circle is drawn with a diameter of 4 cm and its center is offset by -0,2 cm.

3. Save your work.

Accomplishments
   • Constructing circles
   • Using point offsets
Making Changes

In this exercise you will modify the part you’ve been constructing. First, you’ll add a cutout section to the bottom edge, and then you’ll change the diameter of one of the holes.

1. Add the cutout, beginning at the midpoint of the bottom edge and extending to the -55° construction line.
   - Select the Connected Lines tool.
   - Click at the midpoint of the bottom line of the part.
   - Move the pointer to the arc to display the center point of the arc.
   - Move the pointer along the -55° line until the intersection of the center point and the -55° line appears.
   - Click.
   - Move the pointer to the intersection of the -55° construction line and the bottom line of the drawing.
   - Double-click.

   The lines are drawn and remain selected.

2. Remove the unnecessary portion of the horizontal line.
   - Select the Simple Trim tool.
   - Position the Trim pointer dot over the line segment you want to discard.
   - Click.

   The line segment is trimmed.

An object is automatically selected when its construction is finished. Both of these new lines are selected because you are using the Connected Lines tool, and both lines are the result of a single process. Once they are deselected, they are considered individual objects.
3. Delete the construction lines since you no longer need them.
   - Choose Delete Constructions from the Layout menu.
   The visible horizontal, vertical, and -55° construction lines created in this tutorial are removed. The Drawing Assistant's dynamic, on-the-fly construction lines continue to display when you move the pointer near geometry.

4. Change the diameter of the hole on the right to 3 cm.
   - Click the Selection tool.
   - Click the smaller circle.
   - Choose Edit Objects from the Edit menu.
   - Click the word diameter in the Edit Objects dialog box.
   - Type 3 and press Enter.
   The original circle is redrawn with a 3-cm diameter.
   - Close the Edit Objects dialog box by double-clicking the Close box in the title bar.

5. Change the thickness and color of the lines.
   - Double-click the Selection tool.
   Everything in the drawing is selected.
   - Pull down the Pen menu and drag to display the Weight submenu.
   - Choose 0,35.
   All lines are changed to a medium pen weight.
   - Choose Green from the Color submenu of the Pen menu.
   - Click in the drawing area where there is no geometry, deselecting the lines so that you can see the new color. The lines in the drawing are displayed in green.

6. Save your work.

**Accomplishments**

- Trimming
- Deleting construction geometry
- Editing geometry with the Edit Objects command
- Selecting all objects
- Changing the pen weight
- Changing the pen color
Dimensions

In this exercise you will add some dimensions to the drawing.

1. Dimension the horizontal length of the 45° line.
   * Choose Show Palette from the Dimension menu.
   
   The dimension palette appears
   * Select the Horizontal dimension tool.
   * Select the left end of the line to be dimensioned by clicking the lower endpoint of the 45° line.
   
   The hot spot on the pointer moves to the right.
   * Click the upper endpoint of the 45° line.
   
   The dimension appears, but the text is in a location you may want to change.
   * Move the pointer to the dimension text to display the Move symbol.
   "Drag" the text to the left horizontally until it is about 1 cm from the left leg of the dimension.
   
   The dimension text is repositioned.

2. Dimension the vertical line on the left.
   * Select the Vertical dimension tool.
   * Click the lowest point of the chamfered corner.
   * Click the upper endpoint of the vertical line.

Dimensions automatically go on the Dimension layer rather than on the work layer (except there exists no dimension layer or you have selected a different layer in the Dimension Editor). Only dimensions and construction lines go automatically on their respective layer. If you have removed the dimension layer, you will have to create a new one to complete this exercise. Since the layers are transparent, you see the geometry and dimensions on both layers at the same time.

Take a moment to examine the pointer that appears. The dot on one leg of the pointer marks the hot spot for the action you perform.

The location of the dot indicates which side of the object to select. The dot changes positions as you use the dimensioning tool. This type of pointer is a smart pointer because it gives you important information in a multistep process. Many of Draft-Bord’s tools use the smart pointer.

The order of the selection determines the placement of the dimension text. If you select in the order shown on the smart pointer, the text appears above horizontally dimensioned geometry or to the right of vertically dimensioned geometry. If you select in the opposite order, the text appears below or to the left of the selected geometry.
The dimension appears; however, you should add a tolerance.

- Select **Limits** from the **Preferences** of the **Dimension** menu.

A new group of status boxes appears at the bottom of the screen.

- **Text**

<table>
<thead>
<tr>
<th></th>
<th>Upper (0.003)</th>
<th>Lower (0.001)</th>
</tr>
</thead>
</table>

- **Click the** **Upper** **status box**.
- **Type** **.003** **and press** **Enter**.

The dimension now reflects a **.003 upper tolerance** and **- .001 lower tolerance**.

3. **Dimension the angle of the cutout.**

- Select the **Angular dimension** tool.

- **Click the arms of the cutout, near the lower ends of the lines.**

The angle is measured from the **endpoint** nearest the location you click.

4. **Add a radial dimension to the fillet.**

- Select the **Radial Arrow dimension** tool.

- **Choose No Tolerances** from **Preferences** of the **Dimension** menu to return to dimensions without tolerance.

- **Click outside (but near) the filleted corner. Make sure the on notation appears on the arc.**

The radial dimension appears on the side of the arc where you clicked.

- **Choose Hide Palette** from the **Dimension** menu.

The dimension tool palette disappears.

5. **Remove the angular dimension.**

- **Click the** **Selection** **tool.**

- **Click the text portion of the angular dimension.**

- **Press the** **Back Space** **key.**

The angular dimension is deleted.
6. Save this part with a different name (part1a), so that you can use it later for an advanced exercise.
   • Choose Save As from the File menu.
     The Save File dialog box appears with part1 listed in the File name box and the current file name part1.vlm in the entry box.
     • Click after the 1 in part1.vlm in the entry box.
     • Type a and press Return.
       The part is saved with the new name.

Accomplishments
• Adding dimensions
• Moving dimension text
• Adding tolerances
• Saving a version of a part with a different name

Crosshatching
With the part fully drawn and dimensioned, you can now add crosshatching.

1. Select the boundaries that define the area to be crosshatched.
   • Double-click the Selection tool.
     All geometry is selected.

2. Crosshatch the part, indicating Steel.
   • Choose Crosshatch from the Pen menu.
   • Select Steel from the list of patterns.
     The display box shows the crosshatching exactly as it will appear in the part.
   • Click Apply.
     The part is crosshatched.
   • Close the dialog box.

   • Click anywhere in the drawing area to deselect the part.

3. Save the part once again as part1.
   • Choose Save As from the File menu.
     The file name listed is part1a.vlm.
   • Click after the a in the entry box.
   • Press the Back Space key once to remove the a and press Enter.
     Since you can’t save two documents with the same name in the same directory, you are asked if you want to overwrite the existing file named part1.vlm.
   • Click OK.
     The original version of part1 is replaced with this crosshatched version.

Accomplishments
• Crosshatching a part
• Saving and replacing an existing version
• Renaming a file
Stretching

In this exercise, you will change the basic outline of the part and see how the crosshatching automatically redraws to accommodate the change.

1. **Drag** a selection marquee around the point where the left point of the cutout joins the horizontal line.
   - Click the Selection tool.
   - If any part of the drawing is selected, click anywhere in the drawing area to deselect the part.
   - Position the pointer above and to the left of the point.
   - **Drag** to a location below and to the right of the point.

   The point is selected, as shown below. If you don’t see the square selection point, choose Selectable Points from the Edit menu and select again.

2. Stretch the part so that the left side of the cutout is horizontal.
   - Move the pointer to the selected point until the pointer displays the Move symbol.
   - **Drag** the point upward to the top of the \(-55^\circ\) line, so that the vertical construction line appears. **Do not release the mouse button!**

   With the mouse button still pressed, **drag** downward to the intersection of the Drawing Assistant’s construction lines as shown below.

   * Release the mouse button.

   The part is redrawn, and the crosshatching is updated.

3. **Save** your work.

---

**Dragging** the pointer over this endpoint activates it so that the Drawing Assistant’s construction line passes through it.
**Accomplishments**

- Selecting a point
- Using a selection marquee.
- Activating a point
- Stretching a part

**Rotating**

Now that the part is complete, you can rotate it so that the left line of the newly created cutout is horizontal.

1. Specify the rotation.
   - If the part is not selected, double-click the **Selection** tool.
   - Select the **Rotate** tool from the **Transformation** subpalette.
   - Specify the pivot point (the center of rotation) by clicking the lower endpoint of the left side of the cutout.

2. Specify the beginning **Reference point** by clicking at the control point you moved in the last exercise.

3. Specify the ending reference point by clicking on the horizontal construction line across the bottom of the part.

The part rotates.

Note that the dimensions changed to reflect the new orientation; this is an example of associativity. **DraftBoard** maintains an extensive database describing all geometry so that dimensions and locations can be updated quickly.
2. Reduce the visual display of the part.
   - Select the **Zoom Out** tool to display the entire part on the screen.

   The **Scale** box in the status line displays the current scale.
   - Click a location near the larger hole.
   The magnification of the part is reduced and the location you clicked is in the center of the screen.

3. Save your work.

**Accomplishments**
- Rotating a part
- Observing associative dimensions
- Zooming out to a specific location

**Printing**

For your drawing to be useful, you need to transfer it to paper. If your drawing extends past the boundaries of the paper you are using, you can scale it before printing.

1. Specify the page orientation and paper size.
   - Choose **Print Setup** (Macintosh: **Page Setup**) from the **File** menu.
   - If necessary, specify **Portrait** orientation.

   * If you have a plotter, specify the appropriate paper size.
   * Click **OK**.

2. Specify the exact area to be printed.
   - Select **Drawing Size** from the **Layout** menu.
   - Click **Always Display** to display the gray box representing the maximum plotable area of the page.

   * Click **Fit**.

Your drawing may not look like the right illustration because you may have specified a different printer, plotter, or paper size.

The drawing border is scaled and redrawn so that the part fits on the paper size with the orientation you specified.
• Click OK to leave the dialog box.

3. Print the drawing.
   • Choose Print from the File menu.
     The drawing is sent to the printer or plotter.

   • Choose Close from the File menu.
     You are asked if you want to save.
   • Click OK.
     The document is closed. When you open another DraftBoard document, a new DraftBoard window appears.

**Accomplishments**

• Displaying the paper size in the drawing area
• Scaling the drawing
• Printing the drawing
CHAPTER 4

Advanced Features

Trimming and Relimiting Text
Tangent and Perpendicular Lines
Rotational Copy
Constructing a Side View
Advanced Crosshatching
Mirror Images and Bolt Circles
NURB Splines
Creating a Detail View
Drawing to Scale
GD&T
Advanced Features

In this section, you use some of the more advanced DraftBoard features. While many features are demonstrated, you should look through the User Guide chapters for other features which might be useful to you. In some cases, the exercises do not create a useful part but only show you how to use a feature, such as how to trim two lines to make a corner or how to construct a line tangent to a circle. In other cases you create real parts, such as the front and side view of a flange.

The features covered in this section include:

- Corner trim
- Trim
- Relimit
- Text
- Tangent lines
- Perpendicular lines
- Origin (0,0)
- Circle fillets
- Polar duplicate
- Polygon
- Parallel lines
- Mirror transformation
- Bolt circle
- Parametrics
- Splines
- Smart Walls
1

Trimming and Relimiting

In this exercise, you will investigate some advanced construction techniques. DraftBoard allows you to create corners and trim or relimit lines. When you trim a line it is shortened to its intersection with the selected boundary. Relimiting allows you to extend or shorten a line to the limiting boundary.

1. Open a new DraftBoard document.
   - Choose New from the File menu.

2. Explore the Trim tool.
   - Create an approximation of the lines below.
   - Hold down the Shift key and select the two lines that appear bold in the illustration above.
   - Select the Trim tool.
   - Click the locations indicated below.
     The lines are trimmed.

3. Explore the Relimit tool.
   - Select Undo from the Edit menu four times so that the lines are restored.
   - Click the same locations with the Relimit tool.
     The lines are extended to the boundaries.

4. Explore the Corner tool.
   - Create an approximation of the lines below.
   - Double-click the Selection tool to select all lines.
   - Select the Corner Trim tool from the Trim subpalette.
   - Hold down the Shift key and click inside the top corners as shown below.

The exact figure is not important. You are only learning about the functions of the Trim and Relimit tools.

If you trim on entire entity, a prompt will come up asking if you want to delete the entire item. DraftBoard is making sure you want to remove that piece of geometry before it performs trim.

For Trim—select what you want to throw away.
For Relimit—select what you want to keep.

You can either click each line individually or use Shift-Click, clicking inside the corners.
Click here

The lines are trimmed to create corners.

• Select the Trim tool.

• Click the parts of the lines to be trimmed away (those that extend past the corners) to create the figure below.

5. Delete all geometry.
  • Choose Select All from the Edit menu.
  • Press the Back Space or Delete key.

Accomplishments
• Using the Corner trim tool
• Observing the difference between trim and relimit
• Deleting geometry

Text
In this exercise, you will explore using text.

1. Create a text block.
  • Choose the Text tool.

  • **Drag** a box in the center of the screen—the size isn’t important.

  • Click the **Width** status box.
  • Type 3 and press Enter.

2. Change the text characteristics to 10-point Times *italics*.
  • Choose Times from the Font selections on the Text menu.
  • Choose 10 from the Size selections on the Text menu.

3. Type this text: **Submitted by: Smith Inc.**
  • Press Enter.

4. Draw a box around the text.
  • Select the Rectangle tool.
  • The Text entry box disappears.

  • **Drag** a box around the text so that the text is centered within the box.

5. Group the box and the text so that they can be treated as a single unit.
• Double-click the **Selection** tool.
• Choose **Group** from the **Arrange** menu.
• **Drag** the box around to see that the text and the box act as a single entity.

6. Type a list of notes.
• Create another text box, 5 cm wide.
• Change the text characteristics to accommodate a plotter:
  - **Font:** Plotter
  - **Size:** 3,5 mm
  - **Style:** Normal
• Type the following without pressing **Enter**:
  1. The materials list is included on a separate sheet.

7. Change the indentation so that the text aligns under itself rather than under the number.
• Use the **Selection** tool to select the note text.
• Choose **Indentation** from the **Text** menu.
• Click the entry box **Left Indent** to highlight it.
• Type 0,9.
• Click **OK**.

Use the **Delete** key to make corrections as you type. Also, notice word wrap— the text automatically wraps to the next line when a word extends past the right margin.

The text shows a hanging indent.

8. Make changes to the text.
• With the text still selected, click the **Text** tool.
• Double-click the word **materials**.

The word **materials** and the space after it are highlighted.
• Type **specifications** and press the **Spacebar** once.
• Click after the period that ends the second sentence.
• Press the **Back Space** or **Delete** key.

The period is deleted.
• Press the **Spacebar** once and type the following:
  —see attached sheet.
9. Change the size of the text box.
   • Click the Selection tool.
   • Drag a selection marquee around the right side of the text box.

   The upper and lower corner points of the box are selected.

   1. The specifications list is included on a separate sheet.
   2. Tolerances are specified as needed—see attached sheet.

   The area is resized and the text is redrawn.

   1. The specifications list is included on a separate sheet.
   2. Tolerances are specified as needed—see attached sheet.

10. Explore the text processing functions until you feel comfortable with the tools, then delete all the text you created in this exercise.
   • Choose Select All from the Edit menu.
   • Press the Back Space key to delete all selections.

Accomplishments
   • Entering text
   • Changing text characteristics
   • Grouping entities
   • Specifying a hanging indent
   • Making changes to text
   • Changing the size of the text area

Tangent and Perpendicular Lines

In this exercise, you will explore drawing tangent and perpendicular lines.

1. Draw two circles like those shown below.
2. Construct a line tangent to the lower edges of both circles.
   • Click the Single Line tool.
   • Move the pointer to the circle on the left until the on notation appears.
   • Press and hold the mouse button and move the pointer away from the circle at approximately a 45° angle until the tangent notation appears as shown below.
   • Drag the pointer to the lower edge of the large circle until the tangent notation appears.
   • Release the mouse button.
   The tangent line is drawn.

3. Construct a line perpendicular to both circles.
   • Press the mouse button when on appears on the large circle.
   • Drag directly away from the circle at approximately a 90° angle until the perpendicular notation appears.
   • Drag to the left circle until the perpendicular notation appears.
• Release the mouse button.

The line is drawn perpendicular to both circles.

4. Construct a line perpendicular to the lower straight line and tangent to the larger circle.
   • Press the mouse button when on appears on the lower straight line.
   • Drag at a 90° angle from the line to display the perpendicular notation.

   * Drag the new line along the baseline to the large circle until tangent appears and release the mouse button.

   The line is drawn tangent to the large circle and perpendicular to the lower straight line.

5. Save or discard the file, as you wish.

Accomplishments
• Constructing tangent lines
• Constructing perpendicular lines

Rotational Copy

In the next four exercises, you will construct a flange with a side view.

For this exercise, draw a flange 9 cm in diameter containing four 1,5 cm lugs each with 0,75 cm holes. Center a 1 cm hexagonal hole in the 1,5 cm hub of the flange.

1. Open a new document.
2. Choose a different pen style.
   • Choose Visible from the Pen menu.
   The pen style is now solid, black lines 0,5 mm wide.
3. Draw a 9 cm circle centered at 0,0.
   • Choose Show Grid from the Layout menu, so that you can see the origin.
   The grid appears on the drawing area.
Choose the Center-Point Circle tool.
- Type 9 in the status line and press the Tab key.
- Type 0 and press Tab.
- Type 0 and press Enter.
The 9 cm circle is drawn, centered at 0,0.
- Choose Hide Grid from the Layout menu.
The grid and Coordinate symbol disappear.

4. Draw a 0,75 cm lug hole centered at the top of the 9 cm circle.
The Center-Point Circle tool is still the current tool.
- Click on the 12 o’clock quadrant notation.
- Enter 0,75 in the status line and press Enter.
A 0,75-cm circle is drawn, centered on the top of the 9-cm circle.

5. Draw a 1,5-cm circle with the same center as the 0,75-cm circle.
- Enter 1.5 and press Enter.
Another circle is drawn, centered at the same place and with a diameter of 1,5 cm.

6. Create fillets with the default 0,5-cm radius where the lug joins the flange.
- Click the Fillet tool.
- Hold down the Shift key and click between the two curves, as shown by the x in the illustration below.
- Repeat the process on the other side of the lug.
The fillets are complete.

7. Trim the lug.
- Click the Selection tool.
The last fillet you created is still selected.
- Hold down the Shift key and click the other (unselected) fillet. Both fillets are selected to be used as the boundaries for trimming.
- Click the Simple Trim tool.
- Click the bottom of the 1,5-cm circle and the top of the 9-cm circle.
8. Construct a total of four lugs for the flange.

- Click the Selection tool.
- Drag a marquee around all entities that make up the lug.

The lug is selected.

- Choose Polar Duplicate from the Edit menu.

The dialog box should be set to rotate 4 objects, with the x,y coordinates set at 0,0.

- Click Ok.

The lug is copied, but the 3-inch circle must be trimmed.

9. Trim the circle inside the copied lugs.

- Use the Selection tool and the Shift key to select the fillets for the three copied lugs.
- Choose the Trim tool and trim the circle between the fillets.

The lugs are complete.

10. Construct a 2-cm circle in the center of the flange.

- Select the Center-Point Circle tool.
- Move the pointer to display the horizontal construction line through the left bolt hole.

* Display the vertical construction line for the lower bolt hole and click at the intersection of these two construction lines.

- Enter 1.5 and press Enter.
11. Add the 1-cm (outside measurement) hexagonal hole within the 1,5-cm hub.
   • Select the Inscribed Polygon tool.

   Confirm that the status line shows the x, y coordinates as 0,0. If this is not the case, enter 0 into each of these boxes.
   • Type 1 in the Diameter box (do not press Enter).
   • Press the Tab key to select the Sides box.
   • Type 6 and press Enter.

   The hexagonal hole is drawn and the flange is complete.

12. Save the part, naming it flange.
   • Choose Save from the File menu.
   • Type flange and press Enter.

Accomplishments
   • Displaying the grid
   • Placing geometry at the origin
   • Filleting circles
   • Making multiple selections
   • Trimming unnecessary geometry
   • Rotating and copying the lug
   • Constructing an inscribed hexagon

Constructing a Side View

Create a side view of the flange that is 3 cm thick at the hub and 0,5 cm thick at the lugs.

1. Zoom the part.
   • Click the Zoom Out tool.
   • Enter 0,5 in the status line.

2. Construct a vertical line for the side view that is the same length as the distance from the top of the flange to the center.
   • Click the Single Line tool.
   • Move the pointer to the top of the flange to display the construction line and move to the right and click on the construction line as shown.

   • Move the pointer to the center of the right bolt hole to display the horizontal construction line, then move to the right and click at the intersection of the horizontal and vertical construction lines.
3. Construct the remaining vertical lines of the side view.
   • Click the Parallel Line tool.
   • Drag a line to the right of the vertical line in the side view.
   • Enter 2,5.
     The parallel line is drawn 2,5 cm to the right of the original line.
   • Click the original vertical line.
   • Enter 3.

   The vertical lines are complete.

4. Construct the horizontal lines for the side view.
   • Select the Single Line tool.
   • Draw a horizontal line across the top of the right arm of the side view.

   • Continue drawing the horizontal lines aligned with these locations as shown in the illustration below:
     Top of bolt hole
     Bottom of bolt hole
     Top of hub
     Top of hexagon
     Center of flange

   The lines are drawn and the centerline is selected. If it is not, use the Selection tool to select the line from the center of the flange to the side view.
   • Choose Center from the Pen menu.

   • Select the Selection tool.
   • Click outside the flange to deselect everything.
   • Choose Visible from the Pen menu.
5. Trim the excess lines.
   • Save the drawing in case things don’t go as expected.
   • **Zoom In** on the side view only.
   • Select the trim boundary.

   ![Select this line]

   • Trim the vertical line on the left that extends above the selected horizontal line.

   The vertical line is trimmed.

   • Trim the vertical line that descends from the inside corner to the centerline.

   The trimming is complete.

   • When the drawing looks right, save it again.

6. Create the hub fillet with a radius of 1.5 cm.
   • Select the Fillet tool.
   • Enter 1.5 in the **Radius** box.
   • Hold the **Shift** key down and click inside of the corner of the side view.

   The fillet is redrawn to a 1.5-cm radius.

   • **Zoom out** to see the entire flange.

**Accomplishments**

• Constructing a side view
• Creating parallel lines
• Creating a centerline
• Trimming corners

**Advanced Crosshatching**

In this exercise, you will crosshatch the side view. Since the side view isn’t a single closed figure, you will have to segment some of the lines for the crosshatching to work properly.

1. **Zoom in** on the side view.
2. Select all geometry for the side view by dragging a selection marquee around the side view.
3. Use the **Segment** Tool to break the vertical lines at the **intersection** of the horizontal lines. This is necessary to define a closed boundary to crosshatch.
   • Choose the **Segment** tool from the **Trim** palette.

You can use the **Shift** and **Ctrl** key (Macintosh: **Command** key) for **Stroke zoom**, dragging from the upper left to the lower right across the side view. You can also select the **Zoom In** tool and drag a marquee around the side view. If zooming takes you places you didn’t want to go, choose **Zoom All** from the **Arrange** menu and all geometry appears and fills the window.
Advanced Features

4. Crosshatch the solid sections of the side view.
   - Click the Selection tool.
   - Click anywhere in the drawing area, to deselect the side view.
   - Drag a selection marquee around the top part of the side view.
   - Hold down the Shift key and drag a selection marquee around the lower solid section of the side view.

   Both sections are selected.
   - Choose Crosshatch from the Pen menu.
   - The Iron pattern is already selected and displayed in the pattern box.
   - Double-click the Spacing box.
   - Enter 0,2 and click Apply.
   - Close the dialog box.

   The side view is crosshatched.

5. Save the part.

Accomplishments
   - Segmenting lines
   - Crosshatching complex figures

Mirror Images and Bolt Circles

In this exercise, you will create the bottom half of the side view and add a bolt circle to the front view of the flange.

1. Create the bottom half of the side view.
   - Drag a selection marquee around the entire side view.
   - Select the Mirror Transformation tool.

   You are asked to specify a reference line.
   - Hold down the Ctrl key (Macintosh: Option key) and click on the centerline at two places in the side view.
2. Add a bolt circle to the front view.
   • Select the Selection tool and click anywhere to deselect the side view.
   • Choose Center from the Pen menu.
   • Select the Center-Point Circle tool.
   • Drag from the center of the flange to the center of a bolt hole.
   • Use the Selection tool and click in the drawing area to deselect the circle.
   • Choose Visible from the Pen menu.
3. Save the part and close the document.
   • Close the current DraftBoard window.
   You are asked if you want to save the document.
   • Click Yes.
   The document is saved and its window closed. You may see other windows, if other DraftBoard documents are open.

Accomplishments
• Creating a mirror image
• Creating a bolt circle

NURB Splines
In this exercise, you will create and edit splines and observe the difference between splines constructed through specific points and those constructed from vectors.

1. Open a new document.
2. Select the Through-Points Spline tool.
3. Click points such as those shown below, double-clicking the last point.
   \[
   \times \quad \times 
   \]
   A NURB spline is drawn through the control points you specify.
4. Select the Vector Spline tool.
5. Click the same points (the vertex notation appears at the points you clicked for the first spline).
   A different curve is constructed using the vectors for calculation.
6. Edit the control point in the middle of the original spline.
   - Select the original spline.
   - Choose Show Points from the Layout menu.
     The control points and the endpoint slope controls are displayed.
   - Select the Lock Spline Control Point tool.
   - Click the control points on either side of the point you want to change.
     The points are locked.
   - Deselect the spline.
   - Select the middle control point.
   - Drag the middle control point to new locations and observe how the spline is redrawn.

Accomplishments
- Creating a through-points spline
- Creating a vector spline
- Editing splines

Creating a Detail View

In this exercise, you will create a detail view. A detail view is an enlarged or reduced view of part of the drawing. Detail views are dynamically linked to the part from which they are derived, and modifications made to the part are also made to the detail view. This functionality is called associativity.
1. Create a detail view of the notch from Exercise 8 in the last section of the tutorial, using a 2-to-1 ratio.
   • Open the file named part1a.
   • Click the Detail View tool on the View Control subpalette.
     The Scale box is highlighted in the status line.
     • Enter 2.
     • Drag a frame around the top of the side view, including the notch.
     The enlarged geometry appears in the detail view frame.

2. Fillet the right corner of the notch in the detail view and observe that the geometry in the frame is, indeed, a view of the same part.
   • Click the 2-Entity Fillet tool.
   • Enter 0.25.
   • Select the two lines that form the right corner of the notch in the detail view.
   Both the part and the detail view are redrawn with the fillet.

3. Crosshatch the side view.
   • Deselect the view by clicking outside the view with the Selection tool.
   • Crosshatch the side view with the steel crosshatch pattern.
The side view is crosshatched but the detail view is not.

4. Save or discard the file, as you wish.

**Accomplishments**

- Creating a detail view
- Observing associativity

**Drawing to Scale**

In this exercise you will use the Symbol feature to display a full-scale part. Then you will dimension and scale the part for placement on a standard drawing format. This exercise uses a simple part to demonstrate the procedure you should use to construct more complex full-scale parts. Drawing at full scale has several advantages, the most important of which is that you can start your work without having to specify paper formats or other parameters which only would distract from the design task.

1. Draw a side view of a Phillips-head screw which is 25 mm long and has a thread diameter of 4 mm.
   - Open a new drawing using the **New** command in the **File** menu.
   - Draw the side view of the screw using the drawing tools in the tool palette.

2. Set the specifications for the size paper you will be using.
   - Choose **Print Setup** (**Macintosh: Page Setup**) from the **File** menu.
   - Select the paper size **DIN A4** for a laser printer or **A1** for a plotter.
3. Set the visual scale of the geometry.
   • Choose **Drawing Size** from the **Layout** menu. The Drawing Size dialog box is displayed.

   ![Drawing Size Dialog Box]

   - Click **Fit**.

   The scale is approximately 7:1 but the geometry is visually too large for the page, so you should reduce the scale to 6:1.

   - Enter a scale of 6:1 and click **OK**.

   The screw is scaled to fit the paper size.

   • Click **OK**.

4. Dimension the screw.
   • Choose **Zoom All** from the **Arrange** menu to display the screw at a larger size.
   • Choose the **Horizontal dimension** tool.
   • Click the opposite ends of the screw.
   The dimension displays

   ![Dimensioned Screw]

   - Dimension the diameter of the thread.

5. Place the scaled drawing into a standard A-size drawing format.
   • Choose **Zoom Out** from the **Arrange** menu.
   • Choose **Import** from the **File** menu.
   • Open the **Layouts** directory.
   • Click the **aFormatA** file in **Layouts** directory.
   • Click **Unscale** and **OK** to import the unscaled drawing format.
6. Plot the drawing.
   • If your plotter or printer is set up and if you want a copy of this drawing, choose Print from the File menu. The drawing is plotted.

7. Save or discard the file, as you wish.

**Accomplishments**

• Using a symbol
• Scaling a drawing
• Importing a drawing format

**GD&T**

In this exercise, you will add a GD&T label and feature control frames to the flange construction in this chapter.

1. Open the flange document showing the flange and the side view.
2. Create a datum label A for the upper-right corner of the side view.
   • Choose GD&T from the Dimension menu.
   • Type A in the Datum box.
   • Click the Witness Line button.
• Click the upper-right corner of the side view to indicate the geometry to attach the witness line to.
• Click a location on the construction line above the corner to place the GD&T label.

3. Create a feature control frame for Perpendicularity for the hub of the side view.
   • On Line 1, in the first box, select the Perpendicularity symbol from the pop-up menu.
   • On Line 1, in the second box, select the Diameter symbol from the pop-up menu.
   • On Line 1, in the third box, enter .003.
   • On Line 1, in the fourth box, select the Maximum Material Condition symbol from the pop-up menu.
   • On Line 1, in the fifth box, enter A.
   • Change the entry to B in the lower datum line.
   • Specify Witness Line if it is not already specified.
   • Click the endpoint of the bottom of the hub in the side view to indicate the position for the witness line.
   • Click on the Drawing Assistant’s horizontal construction line to indicate the position of the feature control frame.

4. Create a feature control frame for true position for the lower lug of the flange.
   • In the Label line of the GD&T dialog box, enter 4X Ø .50 to show that the diameter applies to four places.
   • On Line 1, in the first box, select the X at the bottom-right of the pop-up menu to clear the entries in that line.
• Select the True Position symbol from the menu.

• On Line 1, in the second box, select the Diameter symbol from the menu.

• On Line 1, in the third box, enter .003.

• On Line 1, in the fourth box, select the Maximum Material Condition symbol from the menu.

• On Line 1, in the fifth box, enter A.

• Skip the sixth box.

• In the seventh box, enter B.

• In the eighth box, select the Maximum Material Condition symbol from the menu.

• Enter .5 in the Projection box.

• Delete the entry in the lower Datum line.

• Specify Arrow Line if it is not already specified.

• Drag from the hole of the bottom lug on the flange straight down to indicate the position of the arrow and the label.

5. Edit the second feature control frame.

• Select the second frame you created.

• Choose GD&T from the Dimension menu.

• Change the .003 entry to .005.

• Click Edit.

  The text changes in the frame.

6. Save or discard the file, as you wish.

Accomplishments

• Creating a GD&T label

• Editing a feature control frame
Parametrics

Introduction into Parametrics
Drawing with Parametrics
Variable Parametrics
Creating Symbols
**Parametrics**

Besides the Drawing Assistant *Integrated Parametrics* is the most powerful single feature built into *DraftBoard*.

It provides the user with the ability to sketch out the basic shape of a design concept and dimension it with variables, then assign values to the variables and have *Parametrics* accurately reshape and resize the design.

Because of this ability to use variables, a single parametric drawing can take the place of hundreds of similar drawings, given the user endless *what-if* scenarios, and unlimited variations of the original design.

The unique thing about Parametrics in *DraftBoard*, is that it is fully integrated into the software. It’s not an add-on or an afterthought. This allows *Parametrics* to work intimately with the whole program, while at the same time staying out of the way until it is needed.

In this chapter you will learn the basic principles of *Parametrics*. Therefore take enough time to study how *Parametrics* work. Only then you will be able to create your own powerful parametric symbols.

In detail this chapter covers the following topics:

- Introduction into Parametrics
- Drawing with Parametrics
- Variable Parametrics
- Creating Symbols
Introduction to Parametrics

Because it is so powerful, Parametrics is also quite deep. While nothing about Parametrics is particularly difficult, there is a lot to know. The typical user should have little trouble absorbing the information necessary to learn Parametrics, if presented in an organized manner. There lies the purpose of this chapter. It will give you all the knowledge you need to put Parametrics to work for you.

Topics

The understanding of Parametrics is achieved by learning the following:

1. The Point-Driven nature of Parametrics.
   As part of this the user must be able to recognize and identify the actual object points associated with the geometry on the screen.


3. The way how Parametrics thinks:
   • What does it expect?
   • How does it operate?
   And
   • What does it know?.
   The user must learn to think like Parametrics in order to best be able to set up a drawing the way that Parametrics want it set up.

4. What to do when a part doesn’t resolve.
   There are two types of error messages that Parametrics will provide if the resolve operation has trouble. Understanding this, and the associated hints that come along with them will provide the final key to unlocking the powerhouse that is Parametrics.

Points: The focus of Parametrics

Every object in DraftBoard has certain critical points associated with it.

• A Line has a point at each end.
• A Circle has a point at its center and one on its circumference.
• An Arc has a point at each of its two ends and one at its center.

These points are used by DraftBoard to both create and maintain the objects themselves. A line cannot be created without first defining its endpoints. A circle must be defined by its center and radius points. And so on.

Only by defining the points of an object, is the object able to take shape.

To Parametrics, the points on an object are more important than the object itself.

The Points of an object can be displayed by using the Show Points command in the Layout menu. Visible points will be marked by small diamonds. Points should be always visible when defining parametric objects.

Identifying Points

All points of an object are critical for Parametrics (whether they are visible or not). The whole job of Parametrics is to define the location of these points throughout the drawing. This is why we refer to Parametrics as being Point-Driven. Parametrics is linked to then drives these points

Since it is important for the user to utilize these points, it is therefore important for the user to be able to identify these points. So let us look at the following example to illustrate this.

Look at the location labelled A through F in the following Latch Plate drawing and count how many Points are lying on top of each other at each spot. The answers may surprise you in some cases, so we will look at them one at a time.
Location A: 2 Location A has two overlapping points: The endpoints of the vertical and horizontal lines.

Location B: 3 Location B has three overlapping points: The two endpoints of the two solid lines plus one endpoint of the dotted horizontal line.

Location C: 4 Location C has four overlapping points: The three endpoints of the two solid lines and the dotted line plus the endpoint of the right witness line from the L/4 dimension line.

Location D: 6 Location D has six overlapping points: The two endpoints of the two solid lines plus the four endpoints of the witness lines from the L, H, L/4 and H/4 dimension lines.

This is exactly the kind of place where the user must be careful. It is not always obvious where the endpoints actually lie. To see for sure that the dimension objects overlap, select each of the objects, one at a time, and choose the Show Points command from the Layout menu.

Location E: 3 Location E has three overlapping points: The endpoint of the solid line, the endpoint of the arc plus the endpoint of the right witness line from the H/3 dimension line.

The trick part is, that the right witness lines from the two dimensions L and L/4 both go through the spot at E. These two dimensions both were drawn so that their endpoints are at the center of the circle at location F, not at location E. This is another example of how the user must be certain where endpoints actually are.

Location F: 6 Location F has six overlapping points: The center points of the Circle and the Arc plus the three endpoints of the witness lines from the dimensions L, L/4 and H/3.

The sixth one is from the diameter dimension object D-.125 at the center point of the Circle. To check this endpoint, select the D-.125 dimension and choose the Show Points command from the Layout menu. This is another place in which to be careful, because the endpoints of diameter and radius dimensions is easily overseen.

Location G: 2 Location G has two overlapping points: The center point of the circle and the center point of the diameter dimension D. The two dotted lines don’t have any endpoints at this location, since lines have only endpoints at their ends and not at any intersection points, even when the Drawing Assistant is snapping these points.

This example showed how important it is to identify the exact number of points and how easy it is to misinterpret the location of points.

Most people that are new to Parametrics are often not aware of the actual location of the points in the drawing, and therefore have less success with the Parametrics as a result.

The next part of learning Parametrics is understanding the actual Rules that Parametrics follows.
The Rules of Parametrics

1. Horizontal and vertical lines stay that way.

2. Connected points stay connected.

3. A point of an object that lies on another object (not on its points) will remain on that object, or its mathematical extension.*

4. Objects tangent to each other, remain tangent so long as there is an object point at the point of tangency.

5. Colinear lines stay colinear as long as they share an endpoint or overlap.

6. There must be at least one object in the drawing that is either a vertical or horizontal line, or a vertical or horizontal dimension.*

Parametric Rules in Detail

Now we will look at each one of the rule in detail.

Rule 1  Horizontal and vertical lines stay that way.

This rule is very straight forward. The line(s) may shift up or down, left or right as a result of the resolve operation. They even may change length. But they will remain horizontal and vertical.

Rule 2  Connected points stay connected.

This rule requires a little more talk. Any time you use the Drawing Assistant to snap a point of an object onto a point of another object, those two points are exactly connected. Both of those points share that exact same location.

This is valid for all type of points no matter whether they belong to Lines, Circles, Arcs, Splines or Dimensions. It can be the center point of a circle that is exactly on the endpoint of a line or the endpoint of a witness line that is exactly on the center point of a circle. In fact, there might be situations where six or eight or fifty points all come together a single common location. And every one of them are connected into that one location.

Parametrics cannot and will not break apart connect points.

Rule 3  A point of an object that lies on another object (not on its points) will remain on that object, or its mathematical extension.*

In the following graphic a center point of a circle was placed directly on a line, somewhere along the line, but not at the endpoints of the line.

Then according to this rule, in order to define the position of that circle for Parametrics, you need only to define the vertical distance of the center point along the length of the line (Variable A). It is not necessary to define the horizontal distance to the center of the circle from the right or left side of the line.

If variable A is given a new value (original value -1) then the result of a resolve operation will be that the center point of the circle will be forced to move along the line as shown in the next graphic.
Once placed on the line, the center point of the circle cannot be unhooked from the line. The circle is allowed to slide up and down along the length of the line. But the center point must always lie somewhere on the line.

This rule is still valid, when using a value for Variable $A$ that will place the center point of the circle beyond the end of the line, along the mathematical extension of the line as shown in the next graphic.

This is true for a circle center point on a line, as we have just seen, or for a line endpoint on the circumference or a circle.

**Rule 4**  
Objects tangent to each other, remain tangent so long as there is an object point at the point of tangency.

This is most clearly illustrated by the simple following example of a line connected to an arc so that it is exactly tangent to the arc. There are four different ways that two objects can be set up tangent to each other when considering the points of the two objects. In three of these cases, the initial tangency will be preserved after the Resolve operation. In the fourth case it will not.

The first case is where a line and an arc touch each other, and are tangent, but the tangent point where they touch does not contain an endpoint of either the line or the arc as required by Rule 4. In this case, since there is no common point between the two objects, there is no way to keep the two objects connected, much less tangent to each other.

In the second and third instances as well the line and the circle don’t have a common object point, but in opposite to Case 1, one object point lies on the other object at the point of tangency. In Case 2 one endpoint of the line and in Case 3 an endpoint of the arc. In both cases the line is tangent to the arc. In each of these two cases, the fact that one endpoint lies directly on the other object, builds in some additional constraint creates a situation where Rule 3 is also in effect and Rule 4 is satisfied.

The fourth case is really just a special variation of Example 2 and 3, since not only one but two object points lie at the point of tangency: the endpoint of the line and the endpoint of the arc. And this is more than enough to satisfy Rule 4. (The fact that two objects are hooked together at their endpoints, means that Rule 1 is also in effect.)

Now, as Parametrics attempts to resolve cases two to four, it will be forced to maintain the tangency, as well as any other constraints that have been placed on the geometry by dimensions or other conditions placed on the drawing.

This Tangency rule is valid for any combination of Lines, Arcs and Circles.

**Rule 5**  
Colinear lines stay colinear as long as they share an endpoint or overlap.

The Tangency rule is valid in principle also for Splines and Ellipses, but the current version of Parametrics cannot resolve Ellipses and Splines.
Whenever two or more lines are exactly in line with each other and are touching in some way, either by sharing an endpoint or overlapping by some amount, then these lines will remain in line with each other after a Resolve operation.

They may change their location and orientation in space, but they will do so as a group. They will not loose their Colinearity. The original orientation (horizontal, vertical or rotated at any angle) is not important, important is only their Colinearity.

**Rule 6**

There must be at least one object in the drawing that is either a vertical or horizontal line, or a vertical or horizontal dimension.*

Fortunately, this rule is pretty trivial, since it is most likely that there will almost always be at last one vertical or horizontal line or dimension in your drawing anyway.

This rule comes from the absolute need Parametrics has to be able to orient the entire part with respect to vertical or horizontal.

Without one horizontal or vertical element (line or dimension), Parametrics cannot even begin analysing the part because it does not know how to orient the drawing in Cartesian space.

**Conclusion**

We have six parametric rules. Each one by itself is quite simple. Not surprisingly, when you combine then things get more complex. Therefore you must know and understand them in order to properly be able to set up a part and get it to resolve.

Okay let’s see what we have done. First we have seen that Parametrics is a Point-Driven system, and we have learned how to identify the points that are associated with the drawing. Then we went through the six Rules of Parametrics in detail, and saw what they are all about.

The next thing to do is learn exactly how Parametric goes about its Resolve process. We want to learn how it thinks. This will allow us to do two things: First it will allow us to do the Resolve operation in our mind beforehand, and know whether it is going to work or not. And second, it will give us the ability to go back through it if it didn’t work, and be able to see why not.

**Resolve Process**

When the Resolve command is executed, Parametrics takes the information in the drawing and does two things: It determines the location of every single point in the drawing, and it draws all of the appropriate geometry between those points. And it does all this within the confines of the six rules. How it does is very simple:

**Examining the Layout**

When the Resolve command is received, Parametrics goes in and looks at the drawing. And actually, it sees just about the same thing as you do when looking at the drawing. It sees all the lines and arcs and circles. It can tell that some of the lines are exactly horizontal or vertical. It recognizes that there are dimensions, some with variables and some with numeric values. It identifies Points of Tangency and where points lie on a geometry.

The one thing that Parametrics does not see, is the information that is listed in the Edit Objects dialog box such as length, width, radius, beginning or ending coordinates, or the angle of an object. That includes of course attributes like layer, color or the lock status of an object.

So Parametrics can see the general Layout of the drawing, but does not know anything specific about the size or location of anything.

**Checking the Dimensions**

The only way how Parametrics gets the information to define the shape of the drawing is by reading all numeric values assigned to the Dimensions. It doesn’t matter whether these dimensions contain numerical constants, or variables that have been assigned by the user.

This shows the importance of all dimensions to a parametric drawing, since they finally define the shape the parametric drawing. Therefore a drawing without dimensions cannot be a Parametric drawing.

* This rule is not valid for the case where a single circle and an associated radial or diametrical dimension are the only things to be resolved.
In essence, Parametrics uses only three types of information to resolve a drawing:

- The numerical constant values in the dimensions.
- The variables and mathematical operators assigned to the dimensions.
- The six Rules of Parametrics

Having looked at the drawing as a whole, and having seen the relationship between the different entities, and having also digested the values in the dimension objects, Parametrics begins a systematic resolving process that will define, and then reshape the entire drawing according to the given information and to the Rules of Parametrics.

**Point to Point Calculation**

The resolving process goes something like this: Parametrics looks at the drawing and picks one of the points as a starting location. We don’t know which one Parametrics picks, and it doesn’t matter. The process is the same regardless.

Parametrics goes in and lands on this point. Then, while standing on this point, Parametrics looks around and then heads off towards the neighbouring point, seeing if it can get to that point, based on what Parametrics knows about the information on the drawing.

If everything has been defined correctly, Parametrics will have all the information it needs to know the exact location of that next point, and Parametrics will be able to get there and pin that point down precisely.

If something is wrong or missing, then Parametrics has to stop. Parametrics marks that point for future reference, retraces its steps, and heads off in another direction to see how far it can get.

**Positive Result**

If Parametrics is able to get from one point to the next, to the next, and so on, throughout the entire drawing by figuring out the offsets between each of the points, then the part is found to be completely defined, and the resolve operation will result in reshaping, resizing and redrawing the part.

**Negative Result**

If Parametrics gets stuck each way it tries to go, it will jump completely off the drawing and land on some other point and see how it goes from there. If Parametrics just can’t get around to all the points no matter what it tries, then it will stop, and generate one of the error messages that we will study later.

**Example for a Resolve Operation**

Now let’s see what the parametric process described above might be like in an actual drawing. Let’s follow Parametrics on its journey as it goes through and tries to resolve the following Latch Plate. The Latch Plate is a particularly good part to use as an example, because it makes use of all six Rules of Parametrics. In doing so, we will not see how Parametrics thinks, but we will find out that there are quit a few things that Parametrics already knows because of the rules, that helps it get around the part.

Starting Point As we said before, the first thing Parametrics does after the Resolve command is given, is that it goes in and lands on one of the points. We don’t know which point it chooses to start out on, and it doesn’t matter. Let’s pretend we’re Parametrics, and we’ll drop in and land on **Point A**.
Point A-B

From A we want to define the position of some neighbouring point by figuring out the direction and distance by looking at the geometry and the related dimensions. In our example we try to get to Point B. The direction of the line is Horizontal, and the distance along the line is \( \frac{L}{4} \), as defined by the dimension object right above. It is not to difficult to see that \( \frac{L}{4} \) is correct for the distance, but how exactly does Parametrix know that this line is Horizontal? This information is given by Rule 1, that tells us that all horizontal or vertical lines must stay that way.

Parametrix knows if a line is horizontal or vertical. And if a line is horizontal or vertical, then no other information is necessary to define its direction.

Point B-C

From Point B we can get to Point C in a similar manner, since Parametrix knows the direction (vertical) and the distance (\( \frac{H}{4} \)).

Point C-D

How we get from here to Point D? Again, the direction is horizontal and the distance can be calculated by subtracting the distance \( \frac{L}{4} \) twice from the distance L. The resulting distance to Point D is \( \frac{L}{2} \). This is an example of how Parametrix can see indirect information like this by looking at the drawing as a whole.

Point D-E Part I

The direction (vertical) to get from Point D to Point E is known. But the vertical distance is not as obvious as it may seem, since there are no dimension endpoints hooked directly to the endpoints of line D-E.

But length is indirectly defined by the geometry of the drawing, and a couple of the other rules of Parametric. This is done in the following way.

In this situation, three of the rules are acting at the same time: Obviously Rule 1 Horizontal and Vertical lines must stay that way is in effect. But in addition Rule 2 Connected lines stay connected and Rule 5 Colinear lines stay colinear, also come into play.

The role of Rule 2 is clear. Its job is just to keep everything hooked together. If any one point is forced to move, then all objects connected to that point are forced to adjust to the new location of that point.

It is Rule 5 that provides the key making this situation work. And this is where we get to see why the dotted lines have been placed on the drawing between point pairs B-E, D-H, L-H, and C-K.

Dotted Lines

As mentioned before Parametrix does not know anything about line color, line weight or line pattern. Therefore Parametrix does not recognize if a line is dotted, dashed or solid. All Parametrix sees is a line object that must be resolved by defining it endpoints.

Therefore you must make sure that every line in a drawing is completely defined regardless of its attributes. This includes construction lines created using the Stroke-Construction method, or the Construction dialog box. Even though these lines may at first seem to be infinite, they are not, since they go just slightly beyond the current screen and have therefore endpoints that must be defined.

Good news are that DraftBoard in opposite to Parametrix distinguishes between the different line styles and hides all dotted lines in the Symbol Preview and in a drawing as long as these lines are inserted into a drawing as part of a symbol using one of the Symbol commands.

We can use this fact when designing parametric parts by inserting Dotted Lines when if lines need to be colinear or fulfil another parametric rule but should be hidden in the final parametric symbol.
Point D-E Part II Since the Dotted Line between B and E ties together the two line segments A-B and E-F, it will cause all three of those line segments to be collinear with each other. And now according to Rule 5 those line segments have to stay collinear.

So if point A is caused to move up or down because of the H/4 dimension attached to it, then the other three points B, E and F must move up or down right along with it. In addition all line segments are horizontal that have to stay horizontal due to Rule 1.

Since the H/4 dimension defines the distance between B and C it must also define the distance between points D and E and therefore it defines clearly point E.

Point E-F It is a no-brainer to get to point F from point E. Both direction (horizontal) and distance (L/4) are clearly defined.

Point F-G Part I But now we have reached with point F, a point where a more complex interaction between rules and geometry occurs. To explain this we have to know the following:

What Parametrics can recognizes sitting at a Point When Parametrics sits at a point it knows:
• how many objects have Points at that location and it knows the nature of each of those objects.
• if there is a Point of Tangency at that location.
• if that point is resting directly on another object.

Point F-G Part II Sitting on point F, Parametrics knows that there are three points at this location. So Rule 1 will apply. Parametrics also knows that three points belong to a Horizontal Line object, an Arc object, and a Vertical Dimension object.

Parametrics also sees that there is a tangent tag on this point because the Arc and the Line are tangent to each other. So Rule 4 applies.

And finally, Parametrics sees that this point is sitting right on the right witness line of the Horizontal Dimension object L. Which means that Rule 3 will be in effect.

Parametrics sees that at point F there is the endpoint of a Horizontal Line, and the endpoint of an Arc which is tangent to that line. The pure geometry of this situation tells Parametrics that point F must be Quadrant point of the Arc. Parametrics can tell the Radius of the Arc by seeing that the Dimension H/3 is connected to that Tangent point as well as being connected to the Center point of the Arc.

In addition looking down along the length of the arc, it sees that the arc ends at another Horizontal line that is also tangent to the arc. So from this, Parametrics can gather that the arc must go through exactly 180°, and it must end at another Quadrant point.

This completely defines the direction and distance needed to get from point F to point G. The distance is 2 times H/3, and the direction is vertical, though the route taken to get there is along the arc.

Point G-H To get from point G to point H, Parametrics sees that the geometry forces the L/4 dimension to apply. So distance (L/4) and direction (horizontal) is clearly defined.

Point H-J The distance between H and J can be seen to be the total height H minus twice the radius dimension H/3.
Point J-K
The distance from J to K is forced to be the same as from B to E because of the vertical dotted construction lines that were added.

Point K-L
And the vertical and horizontal distances necessary to get from point K to point L are clearly defined from what we already know (Dimension L/4 and the dotted line between H-L and C-K).

So, we have gotten all the way around the part using information on the drawing, the Rules of Parametric, and the Laws of Geometry. It should be mentioned here that even though we went sequentially around the part from A to B to C and so on, it is not required to do so. There may be times where Parametrics will get stalled at one of the points, but by tracking, and going around another way, Parametrics may still be able to completely define the location of that point.

Defining the Circle Center Points M and N
The location of the circle at point M is completely defined simply because of the location of the center of the arc from F to G is completely defined. Since the two centers share the same point, defining one of them defines both of them. And the size of the circle is defined by the diameter Dimension object D-.125 hooked to it. And the circle at point N is a pure example of the application of Rule 3. Notice that the center of the circle doesn’t have any dimensions directly hooked to it. But because of Rule 3, the center is defined by the fact that it first lies on the horizontal line, and second on the vertical line. If either one of those lines moves, the center of the circle is going to be forced to move with them. So the center of the circle will always be defined by the intersection of those two lines. But it is important to note here that there is no actual point at this location other than the center of the circle. That is, the intersection of two lines does not create a point.

Conclusion
That’s it. We have now completely analysed this part manually. This is the type of thing any user of Parametrics must be able to do with any part under consideration. Because without a complete understanding of the way Parametrics thinks and works, and the ability to predict and cause proper resolution of the part, the power of Parametrics is less available to the user.

Error Messages
No matter how well you think you understand how to apply the Rules of Parametrics, we can pretty much guarantee that sometimes you will wind up with a drawing that does not resolve. When this happens, you will receive a friendly acknowledgment of your failure in the form of an error message. The good news is that this error message will also give information that can help you understand where the trouble is.

Type of Error Messages
There are only two types of Parametric error messages that you will get from DraftBoard. One type appears if you under-define the drawing and the other appears if you over-define it. It’s just a matter of the user being able to speak the language.

<table>
<thead>
<tr>
<th>Type</th>
<th>Error Message</th>
</tr>
</thead>
<tbody>
<tr>
<td>under-defined</td>
<td>Unrelated Groups of Geometry</td>
</tr>
<tr>
<td>over-defined</td>
<td>Geometry Over-constrained</td>
</tr>
</tbody>
</table>

Unrelated Groups of Geometry
This error message appears when ever there is not enough information to completely define the location of all points of the drawing.

![Error Message Example](image)

When this message is displayed it shows the number of unrelated groups and which group is displayed. In addition is there a Next and a Cancel Button.
In addition, *DraftBoard* also highlights some geometry on the screen.

If you press the next button, then a different set of unrelated geometry highlights.

In each case *Parametrics* highlights a set of geometry that it can resolve, because it understands the relationship between all the points in this group.

So somehow there is information missing which defines the relationship between each of these groups. To resolve the part, you must discover what the missing link is, and fix it.

This is done by studying the information *Parametrics* gives you, identifying each of the unrelated groups, and then apply the six *Rules of Parametrics* to come up with a solution. Basically *Parametrics* doesn’t know how to get from one group to the other group. Therefore at least between two group points (one point of each group) neither *Distance* nor *Direction* is defined.

**Solutions**

In general, here are some guidelines that can help you work better with unrelated groups:

1. The bigger the number of unrelated groups it says you have, the more the trouble you are in.
2. Whenever you get a situation when you have only 2 unrelated groups, and for one of them *Parametrics* highlights only one object, or better yet, a single point, that is about the clearest message *Parametrics* can give you: This one object is not related to everything else.
3. Conversely, if *Parametrics* highlights seemingly all or most of the drawing, then it is telling you that it can do virtually everything. Therefore most of the drawing is all right.

It is all the situations between these two extremes where it sometimes become difficult to see exactly how or why the shown groups are unrelated.

Another thing to note here is that there is always more than one solution to a given problem.

**Geometry Over-Constraint**

Now let’s look at the other type of error message. This is the *Geometry Over-Constrained* message.

This message occurs whenever you have specified

- too much information
- or
- conflicting information

in the definition of a part. What has happened is that you have forced *Parametrics* to try to satisfy two conflicting sets of constraints on some particular area of the drawing.

The error message will in addition name the conflicting objects that it cannot do. The two most common things that *Parametrics* will tell you that it cannot do, are that an
• Object X cannot be created through a Point
  or an
• Object cannot be created a Distance X from another object.
And in each case, you will see highlighted geometry that shows you the
exact area that it is talking about.

Solutions
In most cases, the solution to the problem is to remove some bit
of information from the drawing in order to remove the conflict that
exists. This might be a simple case of deleting a line or a dimension
object, or it might require the relocation of some geometry endpoints
to properly define the necessary relationship. It just depends. There is
usually not more than one solution to the problem.

At the end of this Parametric lesson some general advice:

\textit{Just because a Parametric Drawing makes sense to
you, doesn’t mean it is going to make sense to Para-
metrics and vice-versa.}

Accomplishments:
• Knowing and applying the six Rules of Parametrics
• Identifying the number of construction points in a parametric
drawing
• Understanding Error Messages.

Drawing using Parametrics
Of course is the most-used feature of Parametrics the creation of
symbol families, since parametric parts allow to derive as many varia-
tions as you like. But Parametrics provides as well a very elegant way to
solve construction problems or to play through different part varia-
tions to find the final optimized shape.

Look for example at the required steps constructing a triangle conven-
tionally, that is defined by three given lengths for each triangle side.

Using Parametrics for the task saves you a number of construction lines
and is significantly faster.

\textbf{Drawing a triangle with Parametrics}
1. Choose the \textit{Connected Lines} tool.
2. Draw a triangle with no specific side lengths.
3. Dimension each side of the triangle and overwrite in each dimen-
sion the \# Symbol in the Text entry field in the Status line with the
exact measurements wanted for each side.
4. Select the \textit{Resolve} command in the \textit{Parametric} submenu in the
\textit{Edit} menu.

The \textit{Resolve} dialog box is displayed.

The \textit{Resolve} dialog box is empty, since no variables are defined.
5. Move the mouse pointer into the drawing area (it takes the shape of a flipped triangle) and select the lower left corner of the triangle as an Anchor point.

6. Click OK. The triangle will be calculated and redrawn according to the defined measurements.

If you define variables instead of precise measurements you can play through any number of variations of the triangle.

**Accomplishments:**
- Solving construction tasks using Parametrics.

---

**Variable Parametrics**

In this exercise, we will use parametrics with variables to construct a Taper Pin, that we can use later on repeatedly as a symbol with different specifications.

1. Design the Taper pin.
   - Draw the pin axis about 50 mm long using the pen style Center.
   - Draw the shape of the Taper pin according to the following graphic with a diameter of about 4 mm using the pen style Outline.

2. Dimension the Taper pin according to the rules of Parametrics.
   - Display the Dimension palette using the Show Palette command in the Dimension menu.
   - Select the Horizontal dimension tool.
   - Dimension the Pin length as shown in the following graphic.
   - Overwrite the #-Symbol in the Text field of the Status line with the variable l (lower L) and press the Enter key.

   The current measurement will be overwritten with the variable l.

3. Dimension the Taper pin with the variables d and ML.
   - Dimension the left pin project with the variable ML, the right pin diameter and the radius of both pin heads with the variable d.

4. Dimension the right pin project with the constant 5.
   - Select the Horizontal dimension tool.
   - Dimension the right pin project and overwrite the #-Symbol in the Text field of the Status line with the constant 5.
   - Press the Enter key.
5. Dimension the Taper pin with the expression \((L*0.002)+d\).
   - Select the Horizontal dimension tool.
   - Dimension the left diameter.
   - Overwrite the \# Symbol in the Text field of the Status line with the expression \((L*0.002)+d\).
   - Press the Enter key.

The current measurement will be substituted by the expression \((L*0.002)+d\).

6. The Taper pin is now completely defined with the variables \(l\), \(d\), \(ML\), the constant \(5\) and the expression \((l*0.02)+d\). Now we will check if the parametric part can be resolved by assigning values to the defined variables.
   - Select the complete Taper pin including all dimensions.
   - Select the Resolve command in the Parametrics submenu of the Edit menu.

   The Resolve dialog box is displayed.

   The dialog box contains all defined variables.
   - Enter the following values: \(d = 0.6\), \(l = 4\) and \(ML = 3\).
   - Select with the mouse pointer the lower left corner of the Taper pin as an Anchor point.
   - Click OK.

   The Resolve dialog box is closed and the Taper pin will be calculated and redrawn according to the specified values.

7. Undo the calculation.
   When testing a parametric part the resolved variation should be always restored to its original condition, since resolving a part could create a type of variation that can’t be resolved any more.
   - Select the Undo command in the Edit menu.

   The Resolve command is undone and the Taper pin is restored to its original condition.

8. Save the part as Taper Pin.
   - Select the Save as command in the File menu and enter the into the Name field Taper pin.
   - Click OK.

   The parametric part is saved as Paper pin.

9. Show the true measurements of the parametric part.
   - Select all part dimensions.
   - Choose the Edit objects command in the Edit menu.

The Edit objects dialog box is displayed.
• Enter into the Text data field the Symbol #.
• Click the Apply button.
In this exercise you have specified a simple parametric part, that we will use to create a symbol in the following exercise.

Accomplishments:
• Design a parametric part.
• Resolve a parametric part.
• Display the true measurements of a parametric part.

Creating Symbols
In this exercise we will extend the Taper pin, that we have designed in the preceeding exercise, by adding data into a parametric symbol that we can store in a symbol library.

1. Open the drawing Taper pin.
• Open the drawing Taper pin that we have designed in Exercise 3 using the Open command in the File menu.
• Modify the line pattern for the dimensions ML, 5 and (l*0.02)+d.
  The Taper pin is defined by the variables l, d, ML, the constant 5 and the expression (l*0.002)+d. But as a symbol we want to select the part only by its variables l (Length) and d (Diameter).
  In order to hide these dimensions in the Symbol Preview window we will change the line pattern for these dimensions into dotted, since dotted lines are neither visible in the Symbol Preview window nor in any placed symbol.
  • Select the dimensions ML, 5 and (l*0.02)+d.
  • Select the pattern dotted in the Pattern submenu in the Pen menu.

2. Now we will create a parameter table for the symbol.
• Open a new file in a simple text editor.
• Enter in the first line the two attributes PartID and Quantity, followed by the defined variables d, l and ML.
  You must separate each entry by a TAB-Stop and press after the last entry ML the Enter key to get into a new line.
• In the second line you enter all required Attributes and Parameter values as shown in the next graphic. You must separate each entry by a TAB-Stop and press the Enter key once after the last entry.
• Save the file as a text file using the symbol name as file name with the file extension .txt.

When you open a drawing using one of the symbol commands (Insert Symbol or Symbolmanager) and DraftBoard finds a Text file with the symbol name, it will, as soon as you click the Parameter button, display a table containing all defined values.

4. Create a Symbol library.
   • Select the Libraries command in the Symbols submenu in the File menu.
   The Libraries dialog window is displayed.

   • Click the New button.
   The Set Library File dialog box is displayed.

   • Enter the Test.vlb in the Name field and click the Save button.
   The Set Library File dialog box will be closed and the name Test will be listed as a library.

   • Overwrite the name Test in the Rename field with Pins.
   • Click the Rename button.
   The library Test will be renamed in Pins.

5. Add the symbol Taper Pin to the new library Pins.
   • Click the Add button.
   The Add Symbol dialog box is displayed.

   • Select the symbol file Taper Pin.vlm from the directory where you have saved it to and click the Open button.
   The Add Symbol dialog box will be closed and the symbol Taper Pin will be added to the library Pins.

   • Click the Save button.

   • Close the Libraries dialog window by clicking the Close button in the title bar.

6. Place the symbol Taper Pin with the Symbolmanager in a drawing.
   • Display the Symbolmanager using the Symbolmanager command from the Symbols submenu in the File menu.
   The Symbolmanager is displayed.
93

- Select from the Libraries list the new library Pins.

The list window Symbols shows the newly defined symbol Taper Pin. The defined Symbol Variations are listed in the Parameter list window and the specified Attributes and Values for each symbol variation are displayed in the Variables list.

- Select the symbol variation DIN-1 6 x 4 in the Parameter list.

All parametric Variables and Attributes of the selected symbol variation are displayed in the Variables list field.

If necessary you can modify the predefined values.

- Mark the Set option.
- Drag a vector on the drawing area for the insertion point and the orientation of the symbol.
- Click the Set button.

The symbol is placed according to the dragged vector.

7. Replace a symbol by a different symbol.
- Mark the Edit option in the Symbolmanager.

The mouse pointer changes its shape to a wrench tool when you bring it over the drawing area.

- Select the placed symbol on the drawing area.

All related data of the selected symbol including its symbol library are displayed in the Symbolmanager.

- Select the symbol variation DIN-1 6 x 6 in the Parameter list.
- Click the Apply button.

The symbol will be reshaped or substituted by the new variation.

8. Delete the library Pins.
- Select the Libraries command from the Symbols submenu in the File menu.

The Libraries dialog window is displayed.
- Select in the Libraries list window the library Pins.
- Click the Remove button.

The library Pins will be deleted. (The symbol Taper Pin will be kept as DraftBoard drawing, only the library entry will be deleted).
- Click the Save button.

Accomplishments:
- Create Parameter lists.
- Create Symbol Libraries.
- Placing and editing symbols.
Architectural Drawings
Architectural Drawings

In this section, we will create a simple two-dimensional architectural drawing. Using the \textit{Smart Wall} tool and the \textit{Smart Symbols} you can sketch a architectural drawings as fast as using paper and pencil.

The features covered in this section include:

- Drawing Smart Walls
- Placing Smart Symbols
- Scaling Drawings
- Printing Drawings
Creating an Architectural Drawing

In this exercise, you will use the Smart Wall tool to create a simple architectural drawing, a floor plan with outside measurements of 7 meters by 10 meters.

1. Open a new DraftBoard document.
2. Set the units to Meters.
   - Choose Units from Preferences in the Layout menu.
   - Click Meters and click OK.
3. Create two new layers: one for the interior walls and one for the exterior walls.
   - Select Layers from the Layout menu.
   - The Layers dialog box appears.
   - Click New to create another layer.
   - Rename the layer by typing Interior walls in the Rename entry box and click Rename.
   - Click New to create another layer.
   - Rename the layer by typing Exterior walls in the Rename entry box and click Rename.
   - Select Exterior walls and click Current, to make Exterior walls the current layer.
4. Draw the exterior walls
   - Select the Smart Wall tool from the Line subpalette.
   - Enter 24 cm in the T status box to indicate walls that are 24 cm thick.
   - Drag a horizontal line.
   - Enter 7 in the L status box and press Return.
   - The line extends off the screen.
   - Choose Zoom All from the Arrange menu.
   - Press and hold the Shift key and drag down vertically from the endpoint of the line at the upper-right corner.
   - Enter 10 and press Enter.
   - A corner is made between the first and second line, and the second line extends off the screen.
• Choose **Zoom All** from the **Arrange** menu.

![Architectural Drawing](image)

• Complete the rectangle, using the **Shift** key while **dragging** the third wall.

![Rectangular Diagram](image)

5. Change the current work layer with the **pop-up** layer box at the lower left of the drawing area.

   • Click anywhere in the drawing area, to deselect all walls.
   • Press the mouse button on the box and the menu displays.
   • **Drag** to **Interior walls** and release the mouse button.

   **Interior walls** is now the current work layer.

6. Create a drawing like the one below with two interior walls (10 cm thick) which don’t merge with the exterior walls.

   • Move the pointer along the inner edge of the upper horizontal wall until the notation **midpoint** displays.
   • **Drag** a wall segment about 6 m long.
   • Enter **10 cm** for the thickness of the wall in the status line and press the **Tab** key.
   • Enter **6** in the **L** status box and press **Return**.

   The horizontal wall is not merged with the vertical wall segment, since they are not on the same layer.

   • **Drag** a horizontal wall to connect the vertical wall segment with the right vertical exterior wall.

![Horizontal and Vertical Walls](image)

7. Construct a **1 m** hole through the vertical interior wall, **1 m** distant from the upper horizontal wall.

   • Move the mouse pointer to the inner left corner of the upper horizontal exterior wall.
   • When the **endpoint** notation displays **drag** horizontally toward the center, releasing the mouse button anywhere.

   A **stroke construction** line is displayed through the inner edge of the upper exterior wall.

![Horizontal Wall with Hole](image)
• Select the **Parallel Lines** tool.

• **Drag** the construction line about 1 m towards the middle of the room.

• Enter 1 for the delta distance in the status line and press **Enter**.
  The parallel line is drawn 1 m below the upper exterior wall

• **Drag** the new construction line about 1 m towards the middle of the room.

• Enter 1 for the delta distance in the status line and press **Enter**.
  The second parallel line is drawn 1 m below the second construction line.

• Select both parallel construction lines with the **Selection** tool.

• Select the **Simple Trim** tool from the tool palette.

• Click the **Simple Trim** tool on the vertical interior wall between the two construction lines.
  The interior wall is trimmed and the wall segment between the two construction lines is deleted.

8. Add a 1 m door beginning in the upper horizontal exterior wall and a 2,5 m window in the right wall. Both should 25 cm from the wall corner.

• Activate the Layer **Exterior Walls** in the Layer indicator.

• Choose the **Symbolmanager** command in the **Symbols** submenu from the **File** menu.
  The **Symbolmanager** is displayed.

• Choose in the **Symbolmanager** the library **A Door top**.

• Select the symbol **Single Door with one leaf**.

• Select from the Part List **Door 1,01/24**.

• Enter into the field **L** the distance from the wall corner 0,25.
  Press the mouse button at the corner of the upper inside wall and **drag** horizontally toward the center, releasing the mouse button anywhere.
• Click the **Set** button.

The wall geometry is redrawn to accommodate the door.

• Select the library **A Windows top**.

• Select the symbol **Simple Window**.

• Select from the Part List **Window 2,51/24**.

• Enter into the field **L**, the distance from the wall corner **0,25**.

Press the mouse button at the corner of the upper inside wall and **drag** vertically toward the center, releasing the mouse button anywhere.

• Click the **Set** button.

The wall geometry is redrawn to accommodate the window.

9. Move the window and observe how the walls are automatically reconstructed.

• Select the window.

• **Drag** it to the opposite wall.

10. Set the paper size and drawing scale.

• Choose **Print Setup** from the **File** menu.

• Select paper size **DIN A4** and click **OK**.

• Choose **Drawing Size** from the **Layout** menu.

The **Drawing Size** dialog box displays.

• In the **Drawing Scale** entry box, type **1cm:50cm** (this entry is the same as **1:50**)

• Click **OK**.

The **drag** indicates the orientation of the door as well as which way it opens.

The available paper sizes depend on the printer or plotter you have specified.

The **Scale** entry box accepts combinations of units of measure.
11. Segment the exterior walls.
   • Select the two symbols (door and window).
   • Choose the Segment tool from the tool palette.
   • Click with the Segment tool the wall segments besides the
door and the window symbol.
The walls are segmented.

12. Crosshatch the exterior walls.
   • Select by clicking with the Selection tool all visible wall
segments of the exterior walls.
   • Choose Hatch from the Pen menu.
The exterior walls are crosshatched.

13. Ungroup the interior walls.
   • Select the lower vertical and the horizontal interior wall.
   • Choose Ungroup from the Arrange menu.
Both wall segments are ungrouped and loose their smart
features.

14. Fillet the corner of the two interior wall segments.
   • Click the 2-Entity Fillet tool.
   • Enter in the status line 0,4 for the radius of the fillet.
   • Click with the 2-Entity Fillet tool the two ungrouped interior
walls, to fillet the inside and outside corners.
   • Enter in the status line 0,6 for the radius of the fillet and press
Enter.
The interior walls are filleted.

15. Crosshatch the interior walls.
   • Select the upper vertical interior wall segment and all lines
building the filleted interior walls.
   • Choose Crosshatch from the Pen menu.
The Crosshatch dialog box appears.
   • Enter -45° for the hatch angle.
   • Click OK.
The interior walls are crosshatched.

16. Dimension the sides of the building.
17. Save or discard the file, as you wish.

**Accomplishments**
- Using the Smart Wall tool
- Using smart window and door symbols
- Filleting walls
- Crosshatching walls
- Scaling a drawing
3D Construction

Introduction
Constructing a Wedge Die
Creating a 2D Drawing
3D Construction

This tutorial is primarily for people who have a working knowledge of DraftBoard but are new to 3D modelling.

Introduction

The tutorial integrates what you already know about 2D design and drafting into 3D space.

Be prepared to look at things differently. Go through these exercises, and then begin to adaptDraftBoard's 3D functions to your personal work style. You'll soon find that you will never want to go back to paper, or conventional drafting programs again.

If you are accustomed to the paper world, you may know about orthogonal projections. 3D models are inDraftBoard more than orthogonal projections; they are actual 3-dimensional wireframes and surface models which you can rotate and modify in 3D space.

With most CAD programs, knowing the 2D version helps very little towards learning the 3D version of that same program. This is because the two programs are just that; two separate programs. The 3D version is often a whole different ball game, with new tools and new commands. Very little of what you knew in 2D, applies to using 3D. You almost have to start over. This provides a barrier that most people are unwilling, or unable to overcome. For this reason 3D really does not get used much in most programs.

But withDraftBoard only a few items are added for 3D. In fact the main addition is the 3D menu and an extended Views menu. And, if you look at the 3D menu, it may seem like there are surprisingly few items available.

It contains only a number of Plane commands. And you also see Object Rotation, Extrude and Revolve. Having seen this, it is easy to think, Geez, there isn’t much there. Where are all the 3D tools and commands?
The answer is that the 3D tools and commands, are the same ones you were using for 2D. You already know all the 3D tools. Now, it is just a matter of applying them in 3D. In fact, there is only one new concept in 3D. And that is the concept of a \textit{Work Plane}. And, if you have ever done any 3D work in any other program, then you already know about this concept. All you need to learn, is how \textit{DraftBoard} does it.

Learning the 3D Part of \textit{DraftBoard} simply becomes an extension of the 2D features. For new users, \textit{DraftBoard}'s intuitive interface makes 3D wireframe design and drafting effortless. \textit{DraftBoard} will truly become a tool that you will actually use. Before you know it, you'll find yourself working in 3D, and wondering how you got along with out it.

\textbf{Before You Begin}

You should already know how to use \textit{DraftBoard} —how to select and use the tools, how to choose from pull-down menus, and how to enter data in the status boxes. If you aren't familiar with \textit{DraftBoard}, you should go through the \textit{DraftBoard 2D Tutorial} before proceeding with this tutorial.

\textbf{Structure of the 3D-Tutorials}

The Tutorial is composed of three parts. The first part introduces you step by step into the 3D world of \textit{DraftBoard} by constructing a three-dimensional part. In the second part you learn more about the different construction methods of \textit{DraftBoard}. And the third and last part explains you the calculation and representation of three-dimensional surface models.
Constructing a Wedge Die

In the first part of the 3D Tutorial we will construct a Wedge Die Part and then create a 2D Drawing with four views (Top, Front, Right and Trimetric) from the wedge die.

Since working in DraftBoard is a smooth transition from 2D to 3D, you can start the drawing in 2D.

1. Begin with a new document and draw a rectangle. The rectangle you will wind up with is about four times as tall as it is wide. It should be almost as tall as the screen.
   * Select the Connected Lines tool.
   * Draw the first two lines by clicking at points 1, 2, and 3.

Move up and show the intersect, but don’t click this point yet.

2. Display the triad and change to a trimetric view.
   * From the 3D menu, select Show Triad.

This command brings up a small orientation marker in the corner of the screen.
   * Select Trimetric from the Views submenu in the Views menu.

When you began drawing, you were in the Top view. Now, if you select Trimetric from the Views submenu, the Triad changes to show a new orientation of how you are looking at 3D space.

The longest of the three lines is always the x-axis, the next longest is always the y-axis and the shortest line is always the z-axis.
The broken line forms a triangle that indicates where the work plane is. In this case, it is flat on the bottom, between the x- and y-axis. And the rectangle has tilted down to match the triad.

Now you can line up the same intersect point as before, but now you are looking at it from a 3D orientation. And then you can finish off the rectangle.

- Click the final two points, to close out the rectangle.*

Now click on the Scroll Up arrow a couple of times, to move the rectangle near the bottom of the screen.

3. Use the Z-Drawing Assistant to draw in the Trimetric view.
   - Position the cursor above the first point of the rectangle, without clicking, to show the Z-Drawing Assistant.

   - Move up, along the z-construction line and click the end point so the line is about 2/3 as tall, as the rectangle is long. Then, without clicking, go down and touch the midpoint of the line, as shown in the following graphic.

   - Come up the z-construction line, and locate the intersect shown.

   - Click the intersect shown above. Then, move down along the z, and end this line somewhere inside the rectangle as shown. Then move to the left, along the y and locate the intersect shown here. Click this point.
• Now, continue on with the **Connected Lines** tool, and pick the five points shown here. Make sure you use the **Drawing Assistant** construction lines to get the proper alignments. When you get to **point 5**, double-click this point to end the line.

What you are seeing here is one of the unique features of **DraftBoard**. The ability to move around freely in 3D space and just pick points, almost as if you were sketching. But having those points end up precisely aligned in all three axes is something that really sets **DraftBoard** apart.

4. Complete the shape of the wedge by moving copies of the selected lines.

• Select the **Single Line** tool.

• Draw a single line from point 1 to point 2.

• Select the **Arrow** tool.

• Move a copy of that line to the other side by using the **Ctrl** key (Macintosh: **Option** key). Notice that the **Drawing Assistant** helps you by automatically snapping to the endpoints at the start and the end of your move.

• With the **Arrow** tool, select the line shown.

• As before, while the line is still selected, hold down the **Ctrl** key and **drag** a copy of the line in the y-direction, placing it at the corner of the **L**. **Drag** another copy in the z-direction and drop it at the top of the block. Select the long vertical line on the far right side of the part and move a copy of it, as shown. Now, all the lines of the **L** block should be drawn.

As you pick each of these points, notice how the **Drawing Assistant** senses where you are and what other geometry you are near. It automatically provides you with all the alignment construction lines you need to draw this part.

Notice that when the cursor gets near the selected line, it changes from the **Arrow** tool, to the **Four-Way Move** cursor. This allows you to move the selected item(s), as well as make copies while you move it.

You can do the same thing with some of the other lines. You could, if you wanted to, draw these lines using the **Line** tool, but sometimes it’s easier to do it like this.
Now you have completed the outline of the Wedge Die. Because of the Z-Drawing Assistant, this process was fast, and accurate.

5. If you have any doubt if this is truly a 3D object, you can check it with the Trackball.
   - From the Views menu, select Show Trackball.

   The Trackball comes up on the left side of the screen. For the purposes of this tutorial, it works best to have it on the right, so grab it by its title bar, and move it over to the right.

   - Rotate the model using the Trackball. Notice that the Triad appears at the center of rotation, and allows you to see the orientation of the axes as the model is turning.

6. Change the view orientation.
   - You can choose any view, such as Right or Top, by selecting each view from the pop-up menu which appears by pressing on the bottom panel of the Trackball. To continue with the tutorial, return to the Trimetric view by selecting that view from the pop-up menu.
7. Modify your design intuitively in 3D.

- Hold down the Shift-key and drag three selection fences around the four points shown, to select these points. (The one short line in the big fence will also be selected.)

- Release the Shift-key. Grab one of the points (the cursor will change to the Four Way Move Cursor) and drag it vertically. Make sure you see the words align:z at the bottom point as you start to move upward. Make the bottom block approximately twice as thick as it was originally.

- In each of the examples below, use the Shift-key and drag the selection fences shown to select the appropriate points. Then drag one of the points to stretch the part. (You can choose to skip this exercise if you want.)

- Do three Undo commands to get the part back to its original form. (The bottom block is still twice as thick.)

- Regardless of whether you did the steps on the previous page, make sure you do this one. This step is part of the actual shape of the finished part. Select the two points shown in the graphic and stretch the shelf back about two-thirds along the y-axis. As part of the design, you will create a wedge-shaped front, so the face is tilted, like in the graphic.

8. Put a molded surface on the front vertical face.

- Do a Stroke Zoom (that is, hold down the Ctrl and Shift key, and drag the rectangle shown, from upper left to lower right) to get the view shown below.
• Pick the **Connected Lines** tool and draw the line shown, going about two-thirds of the way across the width of the face. Make sure you see the words `align:-45` and `on` before you click the second point.

• Finish the contour by drawing the lines and the arc, as shown. In frame 2, hold the **Ctrl** key to temporarily get the **arc** tool. Make sure that you see the words `align:45` and `on` before you click the second point.

9. Finish the surface by first extruding the contour, along the front face, then by revolving it around the corner of the block, and finally by extruding it along the top face of the block.
   * Select **Zoom All** from the **Arrange** menu.
   * Select **Hide Trackball** from the **Views** menu, since you do not need it now.
   * Select the five lines of the contour that you just drew if they are not already selected.
   * Select **Extrude** from the **3D** menu. The **Extrude** dialog box appears.

You will see now one of the important features in **DraftBoard**. You have to enter a set of numbers in the three text boxes.

The problem is, you do not know what number, and you do not know which box. You know you want to extrude along the vertical line of the face, but you do not know how far that is, and you do not know what direction it is. If you were doing this operation in a conventional CAD program, you would have to stop, and ask the computer to tell you these things, so you could write the numbers down, and then type them into the correct box(s).

With **DraftBoard**, this is easy. Notice the asterisk in the dialog box. Whenever you see an asterisk it means, "Use the cursor to enter values".

* Put the **bulls-eye** cursor on the bottom of the vertical line of the face, press and drag up to the top of the line, and release.
A number equal to the distance of that drag will appear in the dz-box, replacing the -1 that was there.

- Press the OK button.
  The extruded objects will appear.

- Now select the same five contour objects, but select the ones at the top of the extrusion. You are about to revolve these objects about the corner of the block.
- Select Revolve from the 3D menu.
  The Revolve dialog box will appear.

Now you will take this contour and sweep it 90 degrees, using the corner of the block as the axis of rotation. Knowing this, you can type 90 into the Sweep angle box. Use 4 divisions for the # of steps. You probably will have no idea how to fill in the remaining six boxes. But there is an Asterisk again, which means that you can "use the cursor to enter values". Which is good, because all you know is that you want to define the axis of rotation, to be from point 1, to point 2.

- Type 90 in the Sweep Angle box.
- Type 4 into the # of Steps box.
- Hit the Tab key to get the blinking cursor into one of the six remaining status boxes.
- Define the Axis of Rotation by dragging from endpoint 1 to endpoint 2 as indicated in the drawing on the next page. If you drag in the opposite direction, the contour will sweep in the opposite direction. When you release the mouse the data boxes will fill with a series of numbers.

DraftBoard automatically filled in the numbers for the axis and direction of rotation.

- Click on the OK button, or press Return DraftBoard builds the sweep.
• Select the five contour objects at the end of the sweep
• Select Extrude from the 3D menu
• To specify the length and direction for the extrusion, drag from endpoint 1 to endpoint 2 as shown below

• Click the OK button
The contoured face is finished.

10. The extrusion operation has created some lines that you do not need any more. You will want to select these lines and delete them, to clean up your drawing.
• Select the three lines shown by Shift-clicking on them, and then delete them.

11. The next step is to put a hole on the front face of the wedge and extrude it through the part. By doing so, you will learn about a new concept in DraftBoard, the concept of work planes.
Right now, you can see by looking at the triad that the work plane is flat on the bottom. If you were to draw a circle, it would be drawn in that orientation. Try that now. What you want is a circle that stands up along the right face. You must change the work plane to match that face.
• Select Right from the Planes submenu.
Notice that the current Plane is Top or World, as shown by the check mark

The Triad changes to reflect the new orientation of the Work Plane.

• Select the Center-Point Circle tool.
• Touch the midpoint of both the right side and the top edge of the front face to wake these points up. The Drawing Assistant now gives you construction lines off of each point.
• Go to where the Drawing Assistant shows the intersect of the two alignments and just drag the circle right along the face. Release the mouse button when the circle is approximately the size shown on the next drawing.

• Select Extrude from the 3D menu
• Drag from endpoint 1 to endpoint 2 to define the distance and direction you want the circle to be extruded.

• Click OK
The circle will be extruded.

12. The next step to do is to put a hexagon on the sloped face. This is a good exercise because it shows how DraftBoard deals with nonstandard planes. You might guess that in order to draw anything directly on a sloped face, you need to set the work plane to match it. And that is correct. When you go to the Plane submenu, you see that none of the choices you see there are appropriate (Top, Front, Right etc.). For this operation you want to Define a new plane.
But, in this case, there is actually a better way—and that is to pick 3 Point Plane from the 3D menu, because you do know three points on this face. They are the three corners of the plane.
• Select 3 Point Plane from the 3D menu.
Notice the Message Line asks you for the origin, then to indicate first the positive x-direction, then the positive y-direction.
• Click first at endpoint 1 for the origin, then at endpoint 2 for the positive x-direction, and then at endpoint 3 for the positive y-direction as shown in the drawing below.

The Triad changes its orientation to indicate that the current Work Plane is now the same as the sloped face.
Now that the work plane is the way you want it, you can draw the hexagon like this:

- Select the **Circumscribed Polygon** tool

- Touch the two **midpoints** shown to wake them up and let the Drawing Assistant show where the **intersect** is located. This point will be the **center** of the hexagon. You can then **drag** the second point straight up, and the hexagon will be placed onto this sloped face. Release the mouse button when the hexagon is similar to the drawing below.

13. Now extrude the hexagon hole through the part, perpendicular to the face.

- Select **Extrude** from the 3D menu.

- **Drag** one of the points, to some distance below the part along the **z** direction. You will have taken the extrusion too far, but that’s OK for now.

- Release the mouse button and click **OK**.

14. You extended the extrusion beyond the base so you can cut it off at the bottom of the part. To do this you will look at the part from the right side View. Then, you will use the **Trim** tool to cut off the excess.

- Choose the **Right** view, either from the pop-up menu on the **Trackball** or from the **Views** submenu in the **Views** menu.

- Select the bottom line of the part by clicking on it with the **Arrow** tool. This will act as the boundary of the trim.

- Select the **Trim** tool.

- Click on the extrusion lines that extend below the bottom of the part. There should be two lines on top of each other in each case, so you will have to click twice on each line.

- Select and **delete** the lower hexagon.
The hexagon is trimmed to the bottom surface of the part.

* Go back to the Trimetric view.

15. Draw the hexagon on the bottom surface of the wedge.

* Execute a Stroke-Zoom (hold down the Shift and Ctrl-key and drag a diagonal window from upper left to lower right, as shown, to get the larger view)

On the Macintosh you have to hold down the Command key to do a Stroke-Zoom.

In this case, because of the way the lines came out on the trim, use the trackball to rotate the model slightly so that you can see all the endpoints more clearly.

* Using the Connected Lines tool, connect each of the six endpoints to finish the hexagon hole along the bottom of the part. Double-click at the last point (7) to end the connected line.

* Do a Zoom Previous to get back to the previous zoom.

16. Save the view.

* It is a good exercise, to save custom views. The 4th view comes up isometric. Activate it, rotate it slightly and then save the new view. To do this, select Define View from the Views menu. Click on the New button, and then click the resulting OK button. This will create a new view called View 1. You can switch back and forth between this and other views. For the purposes of the rest of the tutorial, it is best to switch back to a World Plane and go back to the Trimetric view.

You have finished the Part! But the tutorial is not done yet. So read on.

In creating this part, several features of DraftBoard were demonstrated. We saw the Drawing Assistant working in 3D, and how it is possible to simply sketch in 3D space, and end up with a precisely aligned and defined part.

We saw how we can easily modify our design by stretching it in all directions with the help of the Drawing Assistant. We then did a complex contour that we extruded and revolved. We changed the work plane and put a hole through the right face. We were able to
easily define a nonstandard work plane and put a hexagon on it, which we then extruded through the part. We were able to trim to the bottom surface of the part and finish out the hexagon hole.

All of this covered many of the common processes that occur while doing 3D modelling. But this is only half the story of DraftBoard. Now we need to get this 3D part into a 2D drawing, because that, after all, is what DraftBoard is all about.

Creating a 2D Drawing

1. Get this part into a 2D drawing with four views (top, front, right, and isometric).

   In DraftBoard all it takes is one command. All we have to do, is select Sheet Into View from the Views menu. A dialog box appears that allows you to specify what layout you would like and the scale. There are many choices in this pop-up menu of layouts that include different variations of view arrangements, surrounded by a border and title block. These choices are user definable. You can even make your own custom layouts.
   - Select Zoom All in the Arrange menu. It is okay to leave the part in a Trimetric view.
   - Select Sheet Into View from the Views menu.

   The resulting dialog box appears:
   - Select 4viewb.vlm from the pop-up menu. Set the Scale to 1.
   - When you are finished, click the OK button
   - Select Zoom All from the Arrange menu

   Notice with just one command you get from a 3D wireframe model to a layout for a 2D drawing. It has the four views, a title block, and a border. It doesn’t get any easier than this.

2. Edit the view windows

   If you do not end up with something similar to what is shown in the previous illustration; that is, if you end up with a drawing where the part is too small or too large in each of the views, then you will have to modify the scale of each of the four views.

   If your drawing looks fine, then skip the next step.
   - Activate one of the views by clicking on it
   - Open the pop-up menu.

   - Select Properties from the pop-up menu.
• Modify the Scale to make the part show up in the view clearer. In this case, since the part is too small at .75 scale, perhaps entering a scale of 1.5 would work better. What ever number you find that works well, make sure you enter the same value for all four of the views.

With the Trackball you can rotate any of the views to something nonstandard.

• Select Trackball from the Views menu.
• Click on the Top View view window to make it active (its Title Bar will turn on).
• Rotate the model in that view by dragging on the Trackball. You can make any of the four views display any custom view (rotate the Right side view next).

• While the right side view is still active, pick Right from the Trackball pop-up menu. Click on the Top view to activate it, and select Top from the Trackball menu to put it back to its orthogonal projection.
• Select Zoom Out in the Arrange menu with the Ctrl key (Macintosh: Option key) pressed down.
• Select Pan in the pop-up menu for the top view.
The cursor will change to a mover hand icon.
• Drag the wedge to the upper left corner of the view window.

• To finish, grab the lower right corner of the view
The cursor changes to an arrow. Drag it up, to reduce the size of the view.

• Grab the Title Bar of the new view and move it into a clean area.

Select Undo until the right view has its original size and position.
3. Create an unfolded view.

A common operation is to create a view on the drawing that looks straight at a specified face. It is similar to looking at a perpendicular angle to that face. It is the Projected View problem from high school drafting class. In DraftBoard you simply activate the right view, and then select **Unfold View** from the **Views** menu.

- Click on the right side view to activate it.
- Pick **Unfold View** from the **Views** menu.
- The message line asks you to "Pick start of fold line".
- Click the mouse button at **endpoint 1** and drag to **endpoint 2**.
- When you release the mouse button, a new view appears on the drawing. (Note, it may appear below your current drawing, so you may have to scroll down to see it.)

4. Make changes to your design.

- In the **top view**, **drag** a selection fence through the part as shown. Make sure the fence crosses the middle of the part, where all the lines are horizontal.
  Notice that the right side of the part is selected in all of the views.
  - **Drag** the corner of the part to the right along the **x-axis**.
The changes occur in all the views.

During dimensioning pay attention to the Triad. The dimensions work only on the current x-y-plane. So a good trick is to pick Set Plane to Screen from the 3D menu. You will see that the triad will show flat in all five views now. All dimensions will work as if it were a 2D-drawing.

* Return the part to its original form by picking **Undo** from the **Edit** menu.

5. **Dimension the part.**
   * Select **Show Palette** from the **Dimension** menu
     The **Dimension tool** palette appears.
   * Select the **Vertical Dimension** tool
   * Click in the **Top** view to activate it
   * Click on the right side of the part from top to bottom to make the dimension appear. You can change its font size to make it readable.

The five views we have here are associative. However, the dimension object we just placed shows up only in the one view, because these views are smart. Dimensions show only in the view in which they were placed. The same is true for **Crosshatching** and **Text**.

6. **Print the drawing.**
   * Hide the **Trackball**, the **Triad** and the **Dimension palette**.
   * Deselect **Draw View Boundaries** in the **Views** menu.
   * Select **Print setup** from the **File** menu and prepare the page setting for your paper and printer.

   * Use the **Drawing size** command (if necessary) to size the drawing to your page size.
• Select **Print** in the **File** menu.

The drawing is printed on the selected printing device.

**Important:** How to calculate *Surfaced Models*, blend out *Hidden Lines* and to dimension surfaced models is explained in Chapter 9 in this Tutorial.
3D Construction Methods

Three Ways to Construct a Box
  Isometric Drawing
  Extrusion
  Interlocking Parts
  Revolve
  Pipe Winch

Cutting an Angle with Isometric Drawing
  Three-Corner Fillets
  Filleting Curves
  Compound Curves
3D Construction Methods

In the following exercises you will study step by step the different construction methods of DraftBoard Unlimited.

What You Will Construct

In these exercises you will construct the following models:

- 3 ways to construct a box
- Isometric drawing
- Extruding a bracket
- Rotating with the Revolve...command
- Interlocking parts
- Pipe winch
- Cutting an angle
- 3-corner fillets
- Fillet curves
- Compound curves
Three Ways to Construct a Box

In this exercise, you will use three methods to draw boxes. In each case you will use the Z-Drawing Assistant to draw the figure. 3D drawing is like isometric drafting.

Method 1

1. Draw a box using the Z-Drawing Assistant.
   - Choose Show Triad from the Views menu.
     
     The triad appears in the upper-left corner of the screen.
   - Choose Trimetric from the Views submenu in the Views menu.
     
     The view is rotated to the trimetric orientation.
   - Select the Connected Lines tool from the Line tool palette.
   - Begin the first line, dragging toward the upper right.

   - Draw the second line segment on the x-axis.

   The x-axis is displayed as perpendicular to the y-axis.
   - Draw the next segment to the intersection as shown below.

   - Complete the rectangle. Don’t double-click when the rectangle is complete.

   - Extend the rectangle along the align:z construction line, clicking the lower corner, as shown.
• Move the pointer to display the **intersection** as shown, and click.

![Diagram showing intersection](image)

• Click the next **intersection** as shown.

![Diagram showing second intersection](image)

• Continue drawing, double-clicking when the second rectangle is complete.

![Completed tri-orthographic sketch](image)

• Use the **Single Line** tool to connect the corners of the rectangles.

The trimetric sketch is complete.

2. Rotate this box to observe that it is a 3D model.

• Choose **Show Trackball** from the **Views** menu. The Trackball displays.

![Trackball display](image)

• Press the mouse button and **drag** on the Trackball. The work plane **triad** displays in the center of the screen as you **drag** the Trackball, and the box you drew rotates as you **drag** on the Trackball.

Method 2

1. On the same drawing area, use the **Move** tool to create a box.

• Rotate the view to trimetric, by choosing **Trimetric** from the **Trackball** pop-up menu.

• Create another rectangle.

![Creating a new rectangle](image)

• If the rectangle is not selected, select it.

• Choose the **Move** tool from the tool palette.

• Hold down the **Ctrl** key (**Macintosh**: **Option** key). The selected object is simply moved. If you hold down the **Ctrl** key (**Macintosh**: **Option** key) during this operation, a copy is moved to the new location.
• Indicate the ending reference point by moving the pointer down until the align:z notation appears, and click when the pointer is about an inch from the corner.

• Use the Single Line tool to connect the corners.

Method 3
1. On the same drawing area with the view rotated to trimetric, use the Extrude command to create a box.
   • Create another rectangle.

   • Select the lines of the rectangle, if they are not already selected.
   • Choose Extrude from the 3D menu.
   • Enter -2 in the Z entry box.
   • Click OK.

2. Manually rotate the view and observe how the models move.

3. Observe the standard views of your models.
   • Select each of the views from the Trackball pop-up menu, one at a time.

4. Delete all three boxes.
   • Double-click the Selection tool from the tool palette. All geometry is selected.
• Press the **Delete** key.
  All geometry is deleted.

**Isometric Drawing**

In this exercise, you will explore the Z-Drawing Assistant further by drawing the figure below. You can observe the snap points and construction lines which aid you in isometric drawing.

1. Set the view to **Trimetric**.
2. Draw the rectangular cube shown below, using whatever method you wish.
3. Draw the rectangular block adjacent to and aligned at the **midpoint** of the back face of the first block.
   • Use the **Connected Lines** tool and begin at the **midpoint** of the upper line.
   • Observing the **align:x** and **perpendicular** notations, begin the construction in the order shown below.
     * Double-click at the first location to end this part of the construction.
     * Complete the block using the **Connected Lines** and the **Single Line** tools.
4. Construct a ramp at the midpoints of the sides of the rectangle at the front of the first block.
   • Use the **Connected Lines** tool and begin at the **midpoint** of the left side of the first block.

It is curious that we talk of isometric drawing and then suggest you use the trimetric view. The term isometric, used by drafters, usually refers to any non-orthogonal drawing. In CAD, you can avoid overlapping lines by using the asymmetric trimetric view.

Remember that you can press the **Esc** key to backtrack while drawing **Connected Lines**.
6. Save the drawing, if you like and close the document.
   • Choose Save from the File menu.
   • Name the drawing.
   • Double-click the Control Menu Button on the upper left corner of the window or select Close in the File menu.
     If you didn't save the document, you are asked at this point if you want to save. Answer that question as you wish.

Extrusion

In this exercise, you will use the Extrude command to draw the bracket below. Extrusions begin by drawing a figure in 2D on the \( x, y \) plane and then extruding it in the \( z \)-direction. Once an object is created, you can rotate it; you can also move the work plane to add detail.

1. Open a new document.
2. Draw the 2D outline of the L-bracket, as illustrated.

   This view of the model is considered the Top view.
3. Extrude the L-shape into a 3D bracket that is 5 cm wide.
   • Select the geometry if it isn’t already selected.
   • Choose Extrude from the 3D menu.
• Enter -5 for the Z entry and click OK.
The part is extruded, but you can't see its depth because you are looking straight at the x, y plane.

4. Rotate the view orientation to the Trimetric view.

5. Move the work plane.
   • Choose 3-Point Plane from the 3D menu.
   • As illustrated below, click the origin, the x-direction, and the y-direction. The message line displays instructions.

6. Create a one-inch hole at the intersection of the midpoint construction lines of the front view of the bracket.
   • Use the Center-Point Circle tool to draw the circle, centered at the middle of the bracket arm.

   • Type 2.0 and press Return.

7. Extrude the circle through the thickness of the bracket.
   • Choose Extrude from the 3D menu.
   • Drag between the endpoints as shown to indicate the direction and length of the extrusion.

   • Click OK.
The hole is extruded.

8. Add a hole in the center of the other arm of the bracket.
   • Reset the work plane by choosing Right from the Plane submenu.
   • Draw the circle using the intersection of the midpoints.
   • Extrude the circle.
Interlocking Parts

In this exercise, you will use layers to construct interlocking parts with precise hole alignment.

1. If necessary, open the bracket file you saved in the last exercise.

2. Enlarge the bracket to fill the screen and select the lines and circles highlighted in the image below. We will use these lines and circles as the basis for building the mating cube.

3. Move copies of the selected lines and circles to a new layer.
   - Choose Layers from the Layout menu.
   - Click New.
     Layer 2 is added to the list.
   - Click Set Work.
     Layer 2 becomes the work layer.
   - Click the Move tool on the tool palette.
   - Hold down the Ctrl key (Macintosh: Option key) and click any endpoint on the selected geometry.
   - Click the same endpoint again.
     The selected geometry is copied at the same location; two sets of geometry now exist, both on Layer 1, but only one of the copies remains highlighted (selected).
   - Select Edit Objects from the Edit menu.
   - Change the Layer entry from Layer 1 to Layer 2.
   - Click Apply.
     The duplicate (selected) geometry is now on Layer 2.

4. Turn off the display of Layer 1.
   - Click Layer 1 in the list box of the Layers dialog box.
   - Click Hide.
     The geometry on Layer 1 is hidden, and Layer 2 is still the work layer.
5. Complete the interlocking piece.

6. Use Show and Hide Layers to display these components of the interlocking model.

Revolve

In this exercise you will draw a goblet using the Revolve command. You begin by drawing half of a 2D object touching the rotational axis.

1. Create a new document.

2. Draw half of a goblet along the vertical axis.
   • Turn on the Grid using the Preferences command in the Layout menu.
   • Draw the outline as illustrated below.

3. Rotate the half-object around the vertical axis.
   • If the geometry is not selected, select it.
   • Choose Revolve from the 3D menu.
   • Specify 360° for the Sweep Angle and 4 for the # of Steps.
   • Click the Axis box.
   • Drag to indicate the beginning and end of the rotational axis.
   • Mark the option Revolve Surfaces.

   • Click OK.

As defined in the Revolve dialog box, the outline is rotated 360° through 4 steps to make a three-dimensional goblet. In addition the surfaces are calculated and displayed as a wire-frame mesh.
4. Rotate the view to get a better 3D angle.

5. Visualize the goblet.
   - Modify the line color from black to grey by first selecting the whole object and then choosing the color Grey in the Color Palette of the Pen menu.
   - Select the view mode Shaded from the View Mode submenu in the Views menu.

6. Save the drawing if you want.

Pipe Winch

In this exercise, you will put all the 3D modelling methods together to draw a pipe winch for an oil rig.

1. Open a new document.
2. Draw the basic shape in the trimetric view.
   - Choose the Trimetric view from the Trackball menu.
   - Use the Connected Lines tool to draw the trimetric figure below using the measurements as illustrated.
3. Extrude the part to a z-depth of 2 cm.
4. Add the roller, using Revolve to turn a rectangle on the slanted face.
   • Zoom in on the part.
   • Use the 3-Point Plane command from the 3D menu to move the work plane.
     Click at the three points shown to indicate the new orientation of the x and y axes, and therefore the work plane.

   • Draw a rectangle, as shown.
     You will notice that you can add this rectangle while you are looking at it from any angle.

   • With the new rectangle still selected, use Revolve to rotate the rectangle 315° (using the default 8 steps).
     • Enter 315 for the angle and 8 for the # of steps into the revolve dialog box. Activate the next data box by hitting the Tab key or clicking in it with the mouse. Then, using the bull’s eye cursor drag from Point 1 to Point 2 and the six data boxes will receive the proper data.

The rectangle rotates.

5. Save or delete the part, as you wish.
Cutting an Angle with Isometric Drawing

In this exercise, you will explore isometric drawing further, and construct this model.

1. Open a new document and show the Trimetric view.

2. Use the Connected Lines tool to follow these steps:
   - 1. align:z
   - 2. intersect
   - 3. align:x
   - 4.
   - 5.
   - 6.

3. Draw the single line representing the width of the part.

4. With all lines selected, except the last one drawn, use the Mirror tool with the copy option (Ctrl key; Macintosh: Option key) to make a mirror copy along the mirror line perpendicular to the midpoint of the width line.

5. Connect the front edges.

6. Use the Connected Lines tool to make the back opening.
   You should change the Work plane to Right to get the are done correctly.
• Continue the construction as shown below:

7. Construct the ellipse on the slanted face.
   • Add construction lines as shown in bold below.

   ![Construction lines](image)

   • Draw another construction line from the *midpoint* of the arc, as shown.

   ![Construction line](image)

   • From the *Front* view, trim this line back to the front face.

   ![Trimmed line](image)

   • Draw a construction line from the *endpoint* of the last line, *perpendicular* to the edge of the slanted face.

   ![Perpendicular line](image)

   • Select the *3-Point Center* Ellipse and specify the points as shown.

   ![3-Point Center ellipse](image)

   The ellipse appears.

8. Delete the construction lines and trim the upper half of the ellipse.

   ![Trimmed ellipse](image)

   The model is complete.

9. Save or delete the part, as you wish.
Three-Corner Fillets

In this exercise, you will work with one of the trickiest 3D modelling problems, trimming the corner of a box where three fillets intersect.

1. Begin by drawing a box.

2. Fillet three corners as shown below.

3. Extrude the fillets.
   - Select the bottom fillet.
   - Choose Extrude from the 3D menu.
   - Drag from one end of the line as shown below to indicate the extrusion distance and click OK.

4. Trim the intersecting lines at the corner.
   - Use the Corner Trim tool and trim the corner as shown.
• Trim the remaining corners, as illustrated.

5. Delete the lines which made up the edges of the cube before you added the fillets.

6. Move the remaining arcs into the proper positions.

7. Check the Top, Right, and Front views to see if they look correct.

8. Save or discard the drawing, as you wish.

Filleting Curves
In this exercise, you will create a fillet at the bottom of a pocket.

1. Begin by drawing a model similar to the one below.

2. Draw a line in the plane of the floor, perpendicular to the pocket side.
3. Construct a fillet between the line on the floor and the line on the side.

4. Extrude the fillet arc along the length of the side, from endpoint to endpoint.

5. Revolve the fillet arc around the corner radius, the number of degrees of the corner angle, using a vector from the corner radius center and 2 copies.

6. Extrude along the next straight line segment.

7. Revolve around the curve, by the degrees of the curve angle, using a vector from the radius center.

8. Complete the boundary by extruding along the lines and revolving around the arcs.

9. Delete the original boundary and the line you added to initially create the fillet.
10. Trim the vertical lines to the top of the new boundary.

The model is complete.

11. Look at the other views (Front, Top, and Right) of the model.

Compound Curve

In this exercise, you will create a compound curve using multiple views.


2. Draw an arc so that the endpoints of the arc lie on a horizontal line.

3. Set up design views, so that you can see your work from different view points.
   - Choose Sheet Into View from the Views menu.
   - Choose 4viewa.vlm from the pop-up menu.
   - Click OK.

   You may have to zoom to see the arc properly.

   The arc is displayed in the views.

4. Extrude the arc in the Z direction.
5. Add lines on the surface of the cylinder.
   • Select the extrusion line at the left end of the arc.
   • Choose **Polar Duplicate** from the **Edit** menu.
     Specify 8 for the number of duplicates.
     Activate the **Center X** data entry box with the **Tab** key.
     First touch the arc with the *bulls eye cursor* to wake up the
     **center** point and then click on the **center** point of the arc.
     Make the step angle 2°.
     Click **OK** to finish the operation.
   • Repeat the process for the other end of the cylinder, making
     the step angle -2°.

![Image of lines on a cylinder
and a process for creating duplicates.](Image)

6. Create the profile of the compound curve.
   Use the **Selection tool/Ctrl key** (**Macintosh: Option** key) to
   make copies of the original extrusion lines in front of the surface
   aligned on the **y** axis.
   • Select the two original extrusion lines that go between the arcs.
   • Move the cursor near an **endpoint** of one of the lines. Hold
     down the **Ctrl** key and **drag** a copy of the lines out along the
     **y**-axis as shown in the next graphic.
   • Connect the top and bottom of the lines with the **Single line**
     tool to make a rectangle.
   • Choose **Front** from the **Planes** submenu in the **3D** menu.
   • **Fillet** the corners as shown.

![Image of a filled rectangle
and a process for creating a filled corner.](Image)

   • Make sure that the fillets are selected and use them as the
     boundary of a trim operation. In the **Front view** trim off the
     parts of the surface lines that appear above the fillets.

![Image of a trimmed surface lines
and a process for trimming.](Image)

7. Complete the curve.
   • Draw a line from the beginning of the fillet to the cylinder.
• Trim the cylinder arc.
• Delete the construction line marking the end of the fillet.
• Repeat the process for the other fillet.
• Delete the profile form.
• Use the Spline tool to connect the endpoints of the cylinder at ends of the surface lines.

8. Save the drawing as you wish.

The drawing must look right in both the top and front views. If it looks right, it is right.
3D Surface Models

Definitions and Rules
Constructing NURB Surfaces
Calculating 3D Surfaces
3D Surface Models

In the following exercises you learn how to create and visualize Surfaces Models.

Definitions and Rules

**DraftBoard** distinguishes between two types of surfaces:

- Trimmed **NURB Surfaces**
- untrimmed **NURB Surfaces**, that are also called **NURB Surfaces**.

**NURB Surfaces (untrimmed)**

**NURB Surfaces are planar** Surfaces. You call a surface planar, when all surface points lie within a two-dimensional plane. In **DraftBoard** these surfaces are called **NURB Surfaces**, since the whole geometry (including straight lines) exists of **Spline Curves**.

Constructing these surfaces is easy, since they are constructed in **DraftBoard** as any other two-dimensional geometry.

**Trimmed NURB Surfaces**

**NURB Surfaces are curved** surfaces, or surfaces that have trimmed boundaries (for example by a hole).

**Structured Surfaces**

**Structured Surfaces** also called **Structured Surfaced Objects** exist always of the original wireframe geometry and the calculated trimmed and/or planar (untrimmed) **NURB Surfaces**.
Rules
When constructing `Surface Models` some rules have to be observed, to make sure that all surfaces are correctly calculated when using the `AutoSurface` command in the 3D menu.

However we practise primarily the construction of curved `NURB Surfaces` in this exercise, we added in the following the summary of all rules you find in Chapter 17 of the Reference manual.

1. **Planar** surfaces may have any number of edges and any number of holes in the face.

2. **Planar** surfaces should have no geometry that would act as a “seam” running across the face, but only geometry that either represents a boundary or hole.

3. **Non-planar** surfaces are not allowed to have more than 4 edges.

4. **Non-planar** surfaces are not allowed to have any holes.

5. When extruding circles to make cylinders, the extrusion line must be connected to the **endpoints** (vertex) of both circles.

6. Circles extruded into cylinders are not allowed to have more than one extrusion line.

7. When doing a **Revolve** operation, use 1 or 2 for \# of Steps. Only for 360° Revolutions the \# of Steps should be 3 or 4. If revolving a circle, the **Axis of Revolution** should run through an **endpoint** (vertex), the Revolution Angle should be 90° and the \# of Steps should be 2.

8. Wireframe geometry must be always connected **endpoints** to **endpoint**. Don’t have overlapping or duplicate lines on top of each other.

   The only exception to this is the next rule:

9. Boundary lines of surfaces may be divided by the boundary line of a second surface into two separate line segments at most.

   If a boundary line is broken into three pieces, the **Auto-surfacing** routine will fail.

   Automatic divisions occur only with ungrouped objects.

10. Whenever you want to return to the original wireframe geometry after having autosurfaced a part, use the **Undo** command instead of the **Ungroup** command.

11. When working with multiple objects, select each one individually and autosurface them one at a time for best results.

Creating NURB Surfaces
When creating (curved) `NURB Surfaces` the most important rule says, that these surfaces must not have more than 4 **Edges**.

In the following exercise we create according to these rules a three-dimensional object existing of trimmed and untrimmed `NURB Surfaces`.

1. Create the following three-dimensional body existing of **planar** and **curved** surfaces.
   - Draw in the **Top view** the following 2D surface using the **Connected line** tool and one of the two **Spline** tools.
   - Select the a **Trimetric** view from the **Views** submenu in the **Views** menu.
   - Select the entire geometry.
   - Extrude the geometry according to the following graphic using the **Extrude** command.
• Select again the entire geometry and change the line color to Grey in the Color palette from the Color submenu in the Pen menu.

• Calculate the object surfaces using the AutoSurface command in the 3D menu.

The created NURB Surfaces will be correctly calculated and represented by wireframe meshes, since all curved surfaces don’t have more than 4 Edges.

• Check the correct surface calculation using the Shaded command in the View Mode submenu of the Views menu.

The shaded view mode shows, when rotating the structured surface object using the Trackball, that all calculated surfaces are closed.

2. Create now the same geometry according to the following graphic but his time with an additional slot.

• Surface the model with the AutoSurface command in the 3D menu.

• Check the correct surface calculation using the Shaded command in the View Mode submenu of the Views menu.

The shaded representation shows, that the front surface wasn’t shaded, since Rule 3 was violated, that allows a maximum of 4 Edges.

An obvious solution would be to extend the vertical line of the slot to the upper and lower edge of the part. This will subdivide the front surface into three surfaces, which would have four edges each.

3. Extend the front vertical line of the slot to the upper and lower part edges.

• Check the correct surface calculation using the Shaded command in the View Mode submenu of the Views menu.

The shaded representation shows, that only the two smaller front surfaces were shaded, but not the larger one.
That is due to Rule 9, that says, that boundary lines are automatically segmented by boundary lines of other surfaces.

In our example the left boundary line of the larger surface was subdivided into three segments by the boundary lines of the two smaller surfaces. Therefore the larger front surfaces has now 6 edges and violates again Rule 3.

A natural solution would be to subdivide the unshaded surfaces by two horizontal lines into three smaller surfaces.

4. Add to the unshaded front surface two additional horizontal lines.

• Check the correct surface calculation using the Shaded command in the View Mode submenu of the Views menu.

The shaded representation shows, that now the larger front surfaces was shaded, but not the adjacent right curved surface. This surfaces now violates Rule 9, since its left boundary line was subdivided into three segments and could with 6 edges not be calculated due to Rule 3.

Therefore we have to insert two additional horizontal lines.

5. Add into the unshaded right front surface two additional horizontal lines.

• Check the correct surface calculation using the Shaded command in the View Mode submenu of the Views menu.

The shaded representation shows that all surfaces were correctly calculated.

Now it makes sense to check whether the two remaining surfaces in the back were correctly shaded or not.

These surfaces made no problems and were correctly shaded since they are planar NURB Surfaces these may have any number of edges.
Calculating the Surfaces of a 3D Model

In this exercise we will calculate the surfaces of the Wedge Die that we have constructed in Chapter 7 in this Tutorial. This exercise is a continuation of that chapter.

1. Open the Wedge Die that we have constructed in Chapter 7.
   • Select Open in the File menu.
   • Choose the directory into which you have saved the Wedge Die.
   • Select the file Wedge Die.vlm and click the Open button.
   The drawing Wedge Die will be opened.

2. Delete all dimensions applied to the Wedge Die.
   Since we want to create new dimensions, we have to delete all dimensions created in Chapter 7.
   • Select all dimensions in the Top view.
   • Select the Delete command in the Edit menu.
   All dimensions will be deleted.

3. Calculate the surfaces of the Wedge Die.
   In DraftBoard you can calculate the surfaces of the Wedge Die using only one command. The calculated NURB Surfaces will be represented as a Wireframe Mesh.
   • Select the entire geometry of the Wedge Die in the Trimetric View.
   • Choose the AutoSurface command in the 3D menu.
   All selected surfaces will be calculated and represented as a Wireframe Mesh.

4. Check the Wedge Die in the shaded view mode.
   Since objects will be always shaded using their line color and the line color Black will result in a representation low in contrast, we will change the line color into Grey.
• Select the entire structured surface object.
• Choose the color Grey in the Color Palette from the Color submenu in the Pen menu. The line color will be change to Grey.
• Select the Shade command in the View mode submenu of the Views menu.

5. Hide the Hidden lines of the model.
All hidden lines will be blended out with the Visible Lines command in the View Mode submenu in the Views menu.
• Select for the Visible Lines representation of the model a trimetric view in the Views submenu from the Views menu.

The hidden lines will be blended out and only the visible lines are shown.
• Select for the trimetric view again the Shaded View mode.
• Blend out all hidden lines for all views except the trimetric view. You just have to activate the views one by one and select for each view the Visible Lines command in the View Mode submenu of the Views menu.

• Select the Show Palette command in the Dimension menu. The Dimension Palette is displayed.
• Select the Vertical Dimension tool in the Dimension Palette.
• Click into the Top View, to activate it.
• Dimension the length of the Wedge Die by clicking its upper and lower corner.

The automatic removal of hidden lines can be only done with Surface models since Wireframe models define only edges and no surfaces.

Check the Triad while dimensioning, since dimensions are always placed parallel to the current work plane indicated by the Triad.
The vertical dimension will be shown in the current view (Top view). Although all five views are associated to each other, the dimensions are placed according to the *Standard Drawing Rules* only in the current view. That is valid as well for all notations and crosshatches.

7. Print the drawing.
   - Hide the Trackball, the Dimension Palette and the Triad symbol.
   - Select the Draw View boundaries command in the Views menu.
     The Mark in front of the command is removed and the drawing boundaries of all views are blended out.

   - Select the Print command in the File menu.
     If you want to print the drawing on a plotter, you should select for the trimetric view the Visible lines representation instead of the shaded view, since plotter are not able to plot images.